CC2652R: Regarding 2M_PHY setting

Part Number: CC2652R
Other Parts Discussed in Thread: SYSCONFIG

Hi,

I was trying to connect device after setting PHY to 2M but my central device not able to connect peripheral when I select 2M PHY setting.

What is the reason behind this ?

And how to solve this issue ?

What all parameter do I need to change so that I can connect to the peripheral ?

My current settings are -

 

  • Hi,

    Could you please verify you have properly set the advertiser / peripheral?

    Connection can be initiated on 2M PHY only if the peripheral advertises using this PHY. 

    Regards,

  • Hi,

    Yes my peripheral is using PHY and I have done following setting in peripheral.

    Thank you

  • Hi,

    Is there HW limitation of CC2652R ?

    Is there any alternate option where 2M is possible ?

    Thank you

  • HI Vidit,

    Can you follow the steps shown below and let me know if this allows you to connect in PHY 2M?

    1. Set Legacy Event Properties Options to "Scannable undirected" on Legacy Advertisement Parameters in simple_peripheral (See screenshot below)

    2.Set Secondary PHY to 2M on Extended Advertisement Parameters on simple_peripheral. Ensure that Event Properties are "Connectable Advertising" (See screenshot below)

    3. Ensure that the initiating PHY is set to 2M on the simple_central SysConfig. (See screenshot below)

    4. Within the SimpleCentral_doConnect() function, change the GapInit_connect() call to the following:

    GapInit_connect(advRpt.addrType & MASK_ADDRTYPE_ID, advRpt.addr, INIT_PHY_1M | INIT_PHY_2M , 0);

    After performing these changes, can you verify if the connection is set up in PHY 2M? If not, then can you provide us with which SDK version you are using?

    Regards,

    Jan