This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

CC2564: Updating Bluetopia Demos to Support CC2564C (Evaluation Module)

Prodigy 30 points

Replies: 4

Views: 184

Part Number: CC2564

I have the MSP-EXP430F5438 Evaluation Board along with the CC2564C dual mode evaluation module.

I've downloaded and installed the Bluetooth Evaluation Software (C:\ti\Connectivity\CC256X BT\CC256x MSP430 Bluetopia SDK\v1.5 R2\MSP430_Experimentor\*)

I've configured code composer to support the build and testing of the SPP demos:  SPPDemo and SPPLEDemo_Lite

Both successfully compile, and download, but:

1. On the SPPLEDemo_Lite demo (which I am attempting to test against Blueterm), I get the following errors on the console

OpenStack().
Bluetooth Stack ID: 1.
Device Chipset: 4.1.
BD_ADDR: 0x88C255D1DC20
GAP_LE_Set_Pairability_Mode Failed: -104.
SetPairable Failed: -104.

Followed by blinking LEDs on the Evaluation Board

2. On the SPP Demo as a client, my attempt to hit a Bluetooth COMM server as the client produces:

Client>inquiry
Client>
Inquiry Entry: 0x9CB6D0E036BC.
Client>
Result: 1,0x9CB6D0E036BC.
Client>
open 1 3
SPP_Open_Remote_Port success.
Client>
SPP Open Confirmation, ID: 0x0001, Status 0x0001.
I have attempted to apply the service pack (CC256XC_BT_SP_v1.1  to the source (essentially downloaded the .zip and added the CC256xC.h to C:\ti\Connectivity\CC256X BT\CC256x MSP430 Bluetopia SDK\v1.5 R2\MSP430_Experimentor\Bluetopia\btpsvend  and added 
#define __SUPPORT_CC256XC_PATCH__  to the BTPSVEND.C
All the same problems persist.   Did I miss something?

  • Hi Richard,

    The CC256XMSPBTBLESW only supports the CC256x (first generation CC256x devices) and CC256XB devices. It does not support the new CC2564C.

    There are 2 main problems when using the older stack like the CC256XMSPBTBLESW with a newer BT4.2 device like the CC2564C.
    - The CC2564C device requires its own unique service-pack. The service-pack for CC256X or CC256XB are not compatible.
    - The BT stack does not recognize the BT4.2 version returned by the CC2564C during the (attempted) initialization. As the result, the stack will fail to initialize.

    Please use the CC2564CMSP432BTBLESW SDK for CC2564C.

    Best regards,
    Vihang
  • In reply to Vihang Parmar:

    I attempted to utilize the baseline radio and board. I guess I didn't. I want to use the MSP430 family, so I will attempt to locate an older CC2564B evaluation module. I will try this again when I get an older module. Thanks for t he quick response.
  • In reply to Richard Hecht:

    One more question … will the Bluetopia Stack (CC256XMSPBTBLESW) be upgraded in the future to support the CC2564C (4.2 and greater) on the MSP430 or will all future dual mode radio stacks only be supported on the 432 family. This will impact my evaluation activities. Thanks.
  • In reply to Richard Hecht:

    Hi Richard,

    Currently there are no plans of updating the CC256XMSPBTBLESW SDK to support BT4.2 and CC2564C.

    Best regards,
    Vihang

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.