This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

CCS: ccs

Prodigy 50 points

Replies: 7

Views: 733

Tool/software: Code Composer Studio

Hello !!!

I have decided to use Microchip_MSP-EXP430F5529LP_EVM development board for development of Bluetooth application using PAN1326B which is based on TI CC2564B blu. chipset.

I have downloaded and installed, CCS- 7.0.0.00042 version and sample code library CC256XMSPBTBLESW-v1.5-R2-Setup for MSP430.

Opened work bench from sample folder for "SPP Demo[Active-Debug-MSP430F5438A Exp]" which are giving some error while build all -

1. Error are listed as below -
a. gmake ; ***[SPP Demo.out] error
b. gmake: Target 'all' not remade because of error
c. Object file have incompatible format object files have incompatible format

2. Warning listed as below -
a. #10424 - D Linker command file has

  • Dear Team,
    I would requesting you, how should i resolve these error. What setting / parameter i need to be change to make it work.

    i am correcting myself.. Bluetooth module is PAN1026 not PAN1326B
  • In reply to Yunoos Desai:

    Further correction : MSP-EXP430F5529LP is a Texas Instruments Dev. board not Microchip :L and PAN1026 has a toshiba Bluetooth controller not a TI controller. It appears that you do not have the correct HW/SW combination. Please see the www.ti.com/.../CC256XMSPBTBLESW for more details.

  • In reply to Vihang Parmar:

    Hi..Thanks for correcting HW details.. But rights now I don't have HW I am planning it..my query are why sample application is not getting build..

  • In reply to Yunoos Desai:

    Hi Yunoos,

    It looks like these errors are caused because of output format (legacy COFF v/s eabi ELF) mismatch between project and libraries. The latest compiler in the CCS7 does not support the legacy COFF mode that the CC256XMSPBTBLESW ccs projects use by default.

    The easiest option I can think is to use the CC256XMSPBTBLESW ccs projects in CCS7 without any change and install compiler version 4.1.x for MSP430. Everything will compile and build without any problem after that.

    Best regards,

    Vihang

  • In reply to Vihang Parmar:

    Hi Vihang,

    Thanks for ur prompt reply.

    I was downloaded compiler 4.1.5 .. but same error..

    Can I pls. suggest me step how to install Compiler ver. 4.1.5 using ccc7..

    Regards,

    Yunoos,

  • In reply to Yunoos Desai:

    Hi vihang,
    Any update on previous request of how to go for download compiler .

    Regards,
    Yunoos
  • In reply to Yunoos Desai:

    Hi Yunoos,

    The video in the link below has all the steps required to install an old compiler.

    Cheers,
    Vihang

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.