This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC2652: Device not found: CC2340R5

Part Number: CC2652

I'm a newbie so forgive if this is a stupid question.

I've been tasked to try get our new CC2340R5 LaunchPad up and running. I have tried to follow the instructions given in the quickstart-guide (some steps seem out of date).
I have reached a point where I believe I have compiled the FreeRTOS project ok, but compiling the uart2callback_LP_EM_CC2340R5_freertos_ticlang project fails.
I get this error: recipe for target 'build-842426095' failed
/ti/boards/LP_EM_CC2340R5: Device not found: CC2340R5RKP
gmake: *** [build-842426095] Error 1
gmake: Target 'all' not remade because of errors.

Any tips on what stuff I'm missing? Perhaps that whole "touch the timestamp" thing in the quickstart-guide didn't work? In creating this thread, TI will not even recognize "CC2340R5" as a part number, so I put in CC2652*. I think I'm on the bleeding edge here.

I'm on Windows 11, CCS 12.0.

  • Hey Steven,

    Can you verify the SysConfig version you are using? Please ensure you are using the version in the MSR page. I would recommend first uninstalling your current version of SysConfig (should be 13). Then run the SysConfig installer in the MSR page. This ensures you have installed the latest package. Secondly, go to Project Properties>General>Products and verify version 13 is enabled.

    I would also recommend making sure you've installed the prerequisite CCS device support package (also in the MSR).

    Please let me know if any of the above helps.

    EDIT: one more thing, the Getting Started section of the CC23xx documentation includes some of these steps. Please see that section in case the quickstart-guide does not cover these steps.

    Second EDIT: I modified your post to tag a more relevant family of devices. In the future, you can also post this to the bluetooth forum instead of other-wireless.

  • Thanks for your reply.

    Project Properties->General-Products say I'm using SysConfig (1.13.0).  Is that the version 13 of which you speak?

    Is there anyway to know if the CCS device support package has been installed? The quickstart guide says CC2340 is too new to be included in the normal packages, so a service pack must be installed over it. I did install the service pack provided by the MSR page, but it did not proceed as the quickstart guide described. Dropping the folder “ccs_base” to my CCS installation did not prompt me if it was ok to overwrite-- it just swallowed it up. I verified that the "ccs base" files were moved, and they were.  So I'm not sure what's up.  Also that thing about touching the timestamp to get CCS to recognize it-- I don't think this worked.  Does touching the timestamp file mean changing the one number that's in the file? Something is amiss. CCS would usually give some message if it was installing something when I restart it, but it didn't.

    Can you point me to this "Getting Started" section f the CC23xx documentation?  I don't see it any of the MSR docs I downloaded.  Again forgive me for being a newbie. It actually took me awhile to figure out what you meant by "MSR" -- I assume you mean "my secure resources".

  • An internal TI engineer helped me with this issue. He said he ran into the same issue, and here is his solution:

    The main cause was that the incorrect sysconfig version was being used.

    In CCS, navigate to Window --> Preferences --> Code Composer Studio --> Products.
    In the “Product discovery path” box, un-check the “C:/ti/ccs1120”.
    Then hit “Apply and Close”.

    The above steps will make sure that CCS is using the CC23xx-enabled SysConfig tool (installed in C:/ti/sysconfig_1.13.0).
    Then re-start CCS and see if the example builds.

    This solution resolved my issue. So now that everything compiles, I move on seeing if the code actually runs. Fingers crossed...