This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430-JTAG-TINY and SmartRF Studio

Other Parts Discussed in Thread: MSP-FET430UIF, CC430F5137

Hi, colleagues!

Is it possible to use SmartRF Studio with MSP430-JTAG-TINY-V2?

I tried this. For the first time, when I connected a debugger (after all drivers installed) I received the following message:

And at this point I might make a mistake.

Instead of answer "Yes" (the left button means this word :-)  ), I press "No" (right button).

After starting the Olimex MSP430 Programmer that program performed some upgrade procedure. And now the flash programmer (in SmartRF Programmer) gives the following information:

And now SmartRF Studio doesn't see any chip connected.

Did anybody use MSP430-JTAG-TINY-V2? If it so what should I do to make it possible?

Thanks!

  • Hi Yourij,

    The only MSP430 device supported by SmartRF Studio is CC430. In order to use SmartRF Studio with CC430, the evaluation module (E.g. EM-CC430F5137-900) must be connected with the MSP-FET430UIF debugger. I don't know if this is compatible with the MSP430-JTAG-TINY-V2. I have never tried it.

    If you get the message about the "FW update", you have to answer yes in order to use SmartRF Studio or SmartRF Flash Programmer with the connected device. If you don't do the update, the MSP-FET430UIF debugger interface is blocked because it doesn't recognize the FW.

    Your last statement "And now SmartRF Studio doesn't see any chip connected": does it mean that you where able to see the connected chip before using the Olimex MSP430 Programmer?

    Regards,

    Øyvind

  • Hi!

    My answer "no", never. At the very first time I didn't connect JTAG to any  circuit because there was no circuit at all then. But I saw the name "MSP-FET430UIF" instead of  "MSP430-JTAG-TINY-V2" in the flash programmer.

    I didn't update the firmware at the first debugger connection. And I wonder if I can do it again somehow.

    Regards,

    Yourij

  • Hi,

    That it show as "MSP-FET430UIF" suggests that the driver is the same and that it is compatible. I assume you will find this also when you check the properties of the device in the device manager.

    However, if the FW can be updated in the same manner or not I can't tell. I was searching on the web for information and at one place a "olimex.dll" was mentioned. The MSP-FET430UIF is controlled with the msp430.dll and the FW that will be programmed is contained within this dll.

    I also found some informatin on the MSP430 Forum: http://e2e.ti.com/support/microcontrollers/msp43016-bit_ultra-low_power_mcus/f/166/t/19190.aspx.

    If you need more details about the compatibility of the Olimex debugger, I suggest you post a question about this on the MSP430 Forum. If it turns out to be exactly the same, I don't see why this should not work with SmartRF Studio or SmartRF Flash Programmer.

    Regards,

    Øyvind

  • As for properties they belong to MSP430-JTAG-TINY.

    As for driver there are both olimex.dll and MSP430.dll (as well as HIL.dll).

    As for programming there is no problem to do it with MSP430-JTAG-TINY-V2.

    I do ask if I can make SmartRF Studio start the firmware upgrade again. Is there any procedure to do this? Command line for example?

    Why did SmartRF Studio try to make it for the very first time?

    Could somebody answer the question, somebody who took a part in writing a code?

    Regards,

    Yourij

  • For the code of SmartRF Studio and SmartRF Flash Programmer I will try to answer your questions. Both SmartRF Studio and the SmartRF Flash Programmer are using the msp430.dll to interface the debugger. The first thing that happen is the enumeration of connected devices. The number and type of devices can be checked without thinking of the FW version of the debugger. Then for each connected device, it tries to initialize the interface in order to retrieve more information. The return code of this initialization will tell if the FW is up to date or not. If not up to date, an update is required to setup the interface for further actions.

    In your case when you answer "no" to do FW updates, no further actions is done seen from the SmartRF Flash programmer or SmartRF Studio. From the screen shots you have provided it seems you are using the SmartRF Flash Programmer. If you restart the Flash Programmer you should normally be asked again to do the FW update. It seems very strange that you get a "IN USE" listed after the first attempt.

    To be sure I tried the same scenario with the MSP-FET430UIF. First trying to use the SmartRF Flash Programmer and answered "no" to the FW upgrade. Then restarting the SmartRF Flash Programmer. Again I get the question to do FW update.

    I also tried SmartRF Studio. The device can be seen in the device list, but it indicates that "fw update is required".

    A double click on the device to start the Device Control Panel will open a dialog where it will ask again to do an FW update. Answered "yes" to do the updated and when it was finished the device turn up with the correct name and COM port number.

    Actually you will see two devices. This is a bug in SmartRF Studio and will be solved in the next release, but if you close SmartRF Studio and start it again, it will appear as only one device. Then it should be ready for use.

    As I understand from your case, the device doesn't appear at all anymore in SmartRF  Studio. It is difficult for me to say what happend but maybe someone on the msp430 forum will be able to tell more about it. I searched for "Olimex" and found some postings, but nothing directly related with your problem. I hope, if necessary, they will be able to tell you how reprogram the "Olimex" debugger.

    Regards,

    Øyvind 

  • O! Thanks a lot!

    I suppose the issue appears because MSP430 Programmer (Olimex) made some firmware upgrade... (The message was seen during the very first use of the Programmer).

    But nobody from Olimex answered...

    Regards,

    Yourij

  • Hi,

    I have custom CC430F5137 board. Is it possible to connect it to SmartRF Studio with MSP-FET430UIF?

    I am using SmartRF Studio v1.71. FET is present at the bottom screen  and I also did software upgrade proposed by SmartRF. Now it has firmware 3.2.3.2. However it shows that my RF board is UNKNOWN.

    Are custom boards supported? If they are I probably need some firmware for CC430F5137, where I can find it?

    Andres

  • Hi Andres,

    It should be possible to use a custom board if the JTAG interface is connected the same way as the CC430F5137EM. See schematics for details: http://www.ti.com/tool/em430f5137rf900

    The firmware required to communicate with SmartRF Studio will be programmed when you start the Device Control Panel. So if you already have something programmed on the CC430, it will be overwritten by SmartRF Studio.

    Sometimes it is necessary to unplug and plug the MSP-FET430UIF after it has been updated but I guess you already tried that. Check that the driver is properly installed with the latest version. The device should be recognized as a "CDC" device. See screen shot from Device manager:

    If it is not a "CDC" device, the driver must be uninstalled and installed again. Uninstall can be done from the device manager. When you connect the MSP-FET430UIF to the USB port again, it will try to install the driver. After installation of SmartRF Studio the correct driver should be available and the installation should happen automatically.

    Regards,
    Øyvind

     

  • OK, JTAG is needed. My board uses SpyByWire.

    I try to solder JTAG wires and try again.

  • Hi Andres,

    I think that SpyByWire should be supported as well. When configuring the interface with MSP-FET430UIF, an option "automatic" is used and normally the FET debugger should detect what to use. To be sure I will try to test this on the CC430EM. Think there are jumpers that enable me to change the connection. I will come back to you with the results.

    Regards,
    Øyvind

     

  • I have tried the CC430F5137EM with SpyByWire connection and this is working fine. The schematics show the jumpers that should be used on JP1 to use SBW(2 jumpers). This could help you to check the connection you have on your custom board.

    Øyvind