This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

SMARTRFTM-STUDIO: CC1101 module not recognised in SmartRF Studio via SmartRF04EB

Other Parts Discussed in Thread: CC1101

I'm trying to talk to a CC1101 module with Smart RF Studio, via a USB SmartRF04EB… but it's not working for me yet

More detail: I'm using SmartRF Studio 7, under Windows 10, on a MacBook Pro (using Bootcamp).

I've installed drivers for the SmartRF04EB, which I think are working as I am seeing *something* under "List of connected devices"

But what I'm seeing is: SmartRF04EB (USB Device ID=0050, Firmware revision=0047. - No chip

If I unplug the CC1101, I get no recognised device, which I assume means that the CC1101 is in some way being recognised, and there's some limited communication going on, but clearly not enough for SmartRF Studio to see the CC1101

This is my first time using SMartRF Studio btw, so apologies if I'm missing anything basic here

Any pointers would be appreciated!

  • Hi,

    I have never worked with a Mac and SmartRF Studio. My impression is that setting up the USB could be tricky but as long as SmartRF04 shows up in SmartRF Studio this should hopefully be ok. 

    When you write CC1101 module, do you then mean a CC1101 EM which you plug into the EM connectors? 

  • In my (limited) experience, you're bang on re. USB in Windows-running-on-Mac. As long as a thing works at all, it works properly, so the fact that the SmartRF04 *is* showing up in SmartRF Studio suggests that there's no problem with the computer+interface part of things.

    Also, the CC101 seems to be getting correct power at least, as in 3.3V to the VCC pins

    The CC1101 module is one of these:

  • I think you're quite correct, in my experience, about USB on Windows-running-on-Mac. If it works at all, it works, and it's usually just a question of installing the right drivers. In this case, as the SmartRF04EB is reporting something to SmartRF Studio, I don't think there's a problem with the basic computer/interface side of things.

    The CC1101 module is an "ICQUANZX CC1101 Wireless Module SMA Antenna Wireless Transceiver Module": 

    It seems to be getting correct power at least, as in 3.3V to the VCC side

  • Could you show how you have connected this module to the SmatRF04 board? 

  • See below, and thanks for quick reply!

  • Hi,

    I did not know that it exist a product called SmartRF04EB that looks like that. For me it's a large green board that is described in

    If I'm not mistaken, the Smart04EB which you have is compatible with CCDebugger (as far as I was able to find out). As far as I can see the pin out on the connector on the CC1101 module you are using is not compatible with the pin out on the CCDebugger, you have to check that you have connected all signals to the relevant pin. 

  • Ah, that definitely gives me something to work with, thanks… I guess I need one of those bigger boards! Just hope I haven't damaged the CC1101 module, though picking up another one would hardly be a big deal, I'm working towards building a custom Arduino-based data display for  my car, showing turbo boost pressure and oil temperature plus tyre data, and I want the CC1101 to pick up the signals from the TPMS sensors. Rather out of my depth, as you can probably guess, but I'll get there in the end…

  • As long as the SmartRF04EB version you have has the same functionality as a CCDebugger you can continue to use it, you just have to rewire some.  

  • I've just tried that, following this pinout: 

    But so, far, same result and same error ("... - No chip")

    I'm pretty sure I've followed the pin assignments correctly (double checking, and looking for where power is coming through).

  • How have you connected pin 2? If you are powering the board from he debugger, this pin should be connected together with pin 9. 

    If you have a picture that shows clearly which pin that are connected where I could be able to check. 

  • Thanks again!

    That pin wasn't connected – I wasn't clear what it was for – but I've just tried again with it connected, but again the result is the same ("No chip")

    I'm attaching a couple of images here, not sure how helpful they'll be

  • Is this a project just to play with this module or is it some volume later on?

    I could not find a datasheet/ connection description that was easy to read for the module when I did a quick look. Do you have this?

  • It's s personal project - it's possible I might sell a few copies, but it's for a custom data display for an old Porsche 944 Turbo, and this part of it is to get TPMS data. Can't really say it's a commercial proposition!

    I used this data sheet, which I believe is the original module this is based on:

    found a data sheet for what I believe to be the module that 

  • I was asking for a pinout/ datasheet for the CC1101 module you are using?

  • Apologies - here's the pinout

  • Bit difficult to see what is going on based on the pictures. Have you measured that you have 3.3 V where you should have it? Double check that the even and odd pins on the debugger haven't swapped space. 

  • Sure, I can appreciate that, sorry they're a bit unclear. But I'm sure the 3.3V is going to the right place, and ditto odd/even on the debugger - the fact that the power is on one side only of the debugger helped there, so I'm pretty confident that was right.

    I'm going to have another look later today and double check everything again… but I have also ordered one of the full-size Chipcon SmartRF04 boards as I'm getting a bit pessimistic about this working, it seems worth trying some new hardware combo go around whatever  the problem is