TRF7970A: Verifying Source 50ohm Tune.

Part Number: TRF7970A

We are currently using the matching circuit for the source depicted in the datasheet (4ohm to 50ohm). It specifies this tuning was performed at full output power. 

Is the TRF7970A outputting a constant carrier for the measurement? 

If so, what register settings were used to set this?

Thank you/

  • Hello Daniel,

    the settings to switch on the RF and also the power settings are in the Chip Status Control Register which is described in the datasheet at page 57:

    https://www.ti.com/lit/gpn/trf7970a

    Best Regards,

    Helfried

  • Hi Helfried,

    I do not see any mention of continuous wave / non-modulated output carrier for measurement purposes 

  • Hi Daniel,

    when setting bit 5 (rf-on) in the CIP Status Control Register you will get an unmodulated 13.56MHz continuous carrier signal.

    There is no other special measurement mode available nor necessary.

  • I wonder If I am missing something,

    I am setting 0x00 0x21, and 0x09 to 0x31, but am getting the following on the network analyzer:

  • I am not really clear what you try to measure. The matching circuit from 4ohm to50ohm has to be calculated and from my understanding can not be measured with the Network Analyzer at full power. The antenna matching to the 50ohm will be done with the Network Analyzer.

    Please explain if I am wrong.

  • With other TI rf products , like BLE products, I had been able to output a continuous wave signal and measure its tuning on an network analyzer and then make matching circuit adjustments. In the TRF7970A datasheet it specifies in section 7.3 the output impedance when operated at full power. That led me to believe they followed a similar practice for the NFC source tuning.

    However, I have been unable to get a constant measurement so possibly this is the wrong approach. 

    How does TI confirm their matching circuit on the source side is correct?

  • Hi Daniel,

    because I am not a specialist for this kind of measurements I have only a basic understanding of how to use a VNA for this. I would think the measurement of the VSWR with the amplifier/matching network terminated with a 50Ohm load should be ok to confirm the correctness of the matching network. This of course, should then be done at full power.

    Do you have no output at all from the transmitter? What microcontroller / firmware are you using to control the TR7970A?

    Best Regards,

    Helfried

  • Hi Helfried,

    We do see an output and it appears to be a continuous wave on the spectrum analyzer. The Network analyzer was flickering a lot unable to take a measurement as if the signal was modulated. I thought we may be having issues with harmonics, but I reduced the span and had similar results. 

    We are controlling the TR7970A over SPI

    Setting 0x00 to 0x21, and 0x09 to 0x31. 

  • Hi Daniel,

    from the register settings you use, you have a 5V system and a 13.56MHz crystal. This is correct to set the RF output. In case you have used before the SW Init direct command 0x03 the ISO Control Register 0x01 must be set back to 0x02 because the SW Init sets a different default value to this register (POR = 0x02; SW Init 0x21).

    Best Regards,

    Helfried