This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-CC1350: CC1350 Flashing using CSS

Part Number: LAUNCHXL-CC1350
Other Parts Discussed in Thread: CC1350, CC1310

Hi, collegues.

Question regarding CC1350 LaunchPad flashing.

Isuccessfully managed to launch the  Wireless Sensor Network example (link below).

Prerequsisites are same as shown in the example.

Two CC1350 LaunchPads,

CSS Version:

Node Example is rfWsnNodeIntFlashOadClient. (I am not intending to use any type of ota updates.)

The issue is after power reset (or manual reset the "Node" board by button near USB connector) it is becoming wsn Concentartor again (or it looks like, at least). I do not know which code is actually executed, but I can see the "Waiting for nodes..." message.

I am expecting, that I am facing some very simple issue with CSS flasing of the device. Why it is started again with not the firmware I flashed durign debug process?

I am not familiar with CSS at all, may be, "Debug" doesn't stand for "flashing" at all and  the code is executing from not the internal CC1350 flash, but from some yet another source?

Please, explain me the issue, or just provide a link to read. 


  • Meaning that you want to flash one board as concentrator and one board as node? Did you have both lauchpads connected when you did this, could it be that you have flashed a different Launchpad than you think you flashed? The LEDs on the XDS110 part of the LP typically blink when you flash the board.

    Test with only one LP connected to the PC.

    The debug button (looking like a small bug) will compile and flash the code.

  • Hi, TER! I tried with only one board connected to PC at a time. I cheked their respective IDs each attempt. The issue is I managed to flash them as a node and concentartor, and even connect the node to the concentrator. Nonetheless, after power-reset the "node" board became concentartor again. And it doesn't matter which one of two boards I flashed with "concentrator" and which as "node". I tired several times: reflashing them with diffrent firmware, making "Node" and "Concentrator" each one. But after power reset they both becoming "Concentartors".  

  • I have tested this on my side and the "node" doesn't do anything after a reset. I don't have a LCD display here at the moment, it could be that it writes something to the LCD display and not the UART. It could look like it starts on something OAD related after a reset and overwrite the flash with something else.

    If  you are not going to use the OAD part I would suggest that you use the rfWsnNode example available under the CC1310 LP and use this (you probably have to set the RF switch on the CC1350 LP to manage to run the example, check one of the basic RF examples for the CC1350 LP on how this is done.) 

    If you plan to use OAD later on, follow the description in the examples readme files on how you set on the examples to get a valid OAD file.  

  • Unfortunatelly, I din't manage to use CC1310 app. I have also tried to use Flash Programmer 2, and the result is the same. The IC don't vene started after flashing. While the verification shows that the binary is there.

  • And I also tried to disbale OnBoard Debugger using Jumpers. Will be taking further experiments... By the way, if I am trying to flash the board as Coordinator, It works well.

  • Unfortunatelly, I din't manage to use CC1310 app

    What did you try?

    If you plan to use OAD later on, follow the description in the examples readme files on how you set on the examples to get a valid OAD file.

    Have you tried this


    It sounds like you are just starting with development on the CC1350. Could you give me some background on the following:

    - Why was CC1350 selected (and not the CC1310)

    - Why did you select these two examples? Could you use some other examples as a start? 

  • What did you try

    I tried to debug the rfNode code, to understand why it has been resetted to some undefined state just after reset. 

    Have you tried this

    Yes, I did. Followed this thread and afterwards "ProjectZero"

    Aftewads, I followed your recommendation to use another example, but not for CC1310, and find the next one fro CC1350 (rfWsnNodeBleAdv). 

    It preserves the firmware after reset, so it solves my issue.

    - Why was CC1350 selected (and not the CC1310)

    I only have two these boards (LAUNCHXL-CC1350) at a current time in office. And I have to do very trivial prototype, forming "one-to-many" network, to explore how "sensor" will work in our expected environment. The key idea is to extend our HomeGateway, which forms ZigBee Network, with Sub-1GHz devices. I completely understand that we do not need CC1350 device, since it is dual-band. I suppose, we should focus on CC1310 device.   

    - Why did you select these two examples? Could you use some other examples as a start? 

    I followed your advice and managed to connect them together. And the "Node" still works after reset. So I will mark you previous post as resolving my issue. Thank you for your help!

    P.S. Unfortunatelly, I didn't solve the issue with the "Node" restarting after power-reset in rfWsnNodeIntFlashOadClient, but that was not my main target.