This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-CC1310: LauchXL-CC1310 Loads with CCS but not UniFlash or SmartRF Flash Programmer 2

Part Number: LAUNCHXL-CC1310
Other Parts Discussed in Thread: UNIFLASH, , CC1310

I created pretty simple program for the LaunchXL-CC1310. Everything works fine when I load it with CCS. If I cycle power after loading the firmware, it runs fine. However, if I load it with either UniFlash or SmartRF Flash Programmer 2, the program doesn't run. Everything appears to load fine using both tools. There are no errors. I'm not using a bootloader. I've tried a lot of various different settings on both tools. I've also tried loading hex and bin files, but nothing works.

Can anyone tell me what I need to do to load firmware with either tool?

  • I figured it out. It turns out I wasn't including the ccfg.c files in my build. Flash Programmer 2 was overwriting the CCFG, which I believe then wouldn't let the CC1310 transfer to the flash application after boot.