This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LP-CC1311P3: CC1311P3

Part Number: LP-CC1311P3
Other Parts Discussed in Thread: UNIFLASH


I tried to read flash memory from CC1311 using the evaluation board (LP-CC1311P3). The evaluation board includes the USB debug probe XDS110.

First step I used the on-board jumpers and configured the as following:

Power_XDS110, GND, 5V, 3V3, Line_TMS and Line_TCK.

I read successfully the flash memory using UniFlash software GUI.  

Second step I tried to connect 2 evaluation boards back-to-back, so in the first board I use as XDS110 debug probe only and in the second board I use CC1311 chip with its peripheral.

Connected lines/signals:

First board: power jumper disconnected

Second board: power jumper connected as Extern_Power.

Between boards connection: GND->GND, 5V->5V, 3V3->3V3, Line_TMS->Line_TMS, Line_TCK->Line_TCK.

XDS110 connection was success but when I try to read flash memory, I got the error: "[ERROR] IcePick_C: Error connecting to the target: (Error -2131 @ 0x0) Unable to access device register. Reset the device, and retry the operation. If error persists, confirm configuration, power-cycle the board, and/or try more reliable JTAG settings (e.g. lower TCLK). (Emulation package"

What may be the reason for this error?

Note: UniFlash app. version:


Alex Katsovich