This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC1110-CC1111: registering on SmartRF Flash Programmer and SmartRF Studio as CC2431

Part Number: CC1110-CC1111
Other Parts Discussed in Thread: CC2431

We purchased and installed 50 CC1110 (CC1110F32RHHR) on to a customer's PCB, but when the customer went to program them, all installed 50pc came up on the SmartRF Flash Programmer and SmartRF Studio as CC2431.

What could be causing this?

What fixes can we apply?

Parts were purchased from Digikey and would be difficult to desolder.

There is no external damage and all markings appear consistent with the CC1110. 

  • I believe Flash Programmer default to some device numbers if it has problems communicating with the chip. I would check the debug interface and also test with as short connection between the debugger and the board as possible. Most times when we have seen something familiar the wires from the debugger has been very long. 

  • Hi,

    We tried swapping out the chip on one board with an older one we have in stock, same rig, and the replaced chip comes up as CC1110 fine. Any suggestions?

    Thank you

  • Since you are able to connect with the chip with SmartRF  Studio:

    - When the chip is reported as a CC2431, does it behave like a CC2431 or a CC1110? The same if you flash a CC1110 image, does it work as intended? If yes, you should try with shorter connections. If not, we need to see a picture of one of the chips to check the markings. 

  • Hi Ter,

    Customer responds as follows:

    "The chip is a CC2431 with printing of CC1110. I can't program this chip."

    Please see the pictures the client sent attached, Thank you.

  • I highly doubt that the chip actually is a CC2431 since CC2431 has 48 pins and CC1110 has 36. 

    Do they see this if they connect a CCDebugger directly to the board? 

  • Yes, these results are from the debugger connected directly to the board.

    As mentioned, we have tried swapping out the chip on one of the problem boards with a CC1110 chip the client had in stock and it read correctly on as a CC1110.

  • Based on the chip marking this is a CC1110F32.

    Have you checked that the cable you are using is not damaged in some way? We have seen customer issues been caused by a partially damaged cable.

    If you still see this issue you can send us a couple of boards and we can take a look at it. 

  • Please send me a friend request here on E2E and then I can send the address etc in a private message.