This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

WL1801MOD: wl1801 ERROR:wl1271_sdio mmc1:0001:2: sdio write failed (-84)

Part Number: WL1801MOD
Other Parts Discussed in Thread: WL1801,

wl1801 ERROR: wl1271_sdio mmc1: 01 01: 2: sdio write failed (-84)

Hello everyone.

There is a problem that the Wi-Fi module is not recognized on the board of Zynq-7000 (model: XC7Z007S-2CLG400E) equipped with wl1801MOD.
As a development environment
Yocto (poky-thud-20.0.3)
linux-kernel 4.14.0
We are developing with our own board using.

As for the problem occurrence situation, when booting linux, the error "wl1271_sdio mmc1: 01: 2: sdio write failed (-84)" occurred, and
It does not recognize wlcore and wlcore_sdio. However, looking at the waveform, it looks like it is working properly.
I tried almost all the solutions to the problem that the error content posted on the forum was similar, but it didn't work.

I've attached a boot log, kernel config, and device tree as it may help resolve this issue.
Also, if you need a circuit diagram, you can attach it.

We would appreciate it if you could help us solve this problem.

sio

/cfs-file/__key/communityserver-discussions-components-files/968/0741.wl1801_5F00_boot_5F00_log.txt

/cfs-file/__key/communityserver-discussions-components-files/968/7558.kernel_5F00_config.txt

/cfs-file/__key/communityserver-discussions-components-files/968/devicetree_5F00_dts.txt