This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

CC3200: Radio Tool not connecting to CC3200

Prodigy 110 points

Replies: 8

Views: 178

Part Number: CC3200

Hi,

I am trying to use Radio Tool to connect to a CC3200 used in our product. I am experiencing some issue with connecting to the CC3200:

Steps I tried:

1.Flash the CC3200 with 1MB

2.Program service pack v1.0.1.13-2.11.0.1

3.Program the radiotool.bin in the radiotool binary folder

4.Try to connect with the CC3200 with radio tool v1.2.5942.19689 and error (-211) appears

Can someone please help as I have tried fiddling around for few hours now without any progress. 

Regards,

Jet

  • Jet,

    Can you share what Comm ports you have available? Have you tried using the other comm port?

    VR
  • In reply to Vincent Rodriguez:

    Hi Vincent,

    I have COM 7, 8, 9 ,10. I tried all available COMM ports but still couldn't connect to the CC3200. I should mention that I am using CC31XXEMUBOOST to connect to the CC3200.

  • In reply to Jet Chong:

    Jet,

    Do you have a CC3200 Launchpad you can use instead, and jumper over the required connections?

    VR
  • In reply to Vincent Rodriguez:

    Hi Vincent,

    Unfortunately I only have 1x CC31XXEMUBOOST and it is not working anymore at the moment. I have ordered another and waiting for it to be delivered.
    Does CC3200 Launchpad makes any difference?

    Thanks,
    Jet
  • In reply to Jet Chong:

    Jet,

    It shouldn't but could be alittle more straight forward for you. Our EmuBoost is primarily used with a CC3100.

    Regards,
    Vince
  • In reply to Vincent Rodriguez:

    Hi Vincent,

    I managed to get everything working with CC3200MODLAUNCHXL but I couldnt get it to work with CC3200LAUNCHXL. I am wondering what is the issue? I am using CC3200MOD on my design.

    From my understanding the 2 versions should be similar enough.

    Regards
    Jet
  • In reply to Jet Chong:

    Jet,

    1) Are you now able to connect your custom board to Radio Tool using the CC3200MODLAUNCHXL?

    2) Did you flash both LaunchPads with the latest Service Pack and Radio Tool image?
    3) Is the jumper configuration on your CC3200LAUNCHXL board the same as your CC3200MODLAUNCHXL?
    a) How are the SOPs configured?
    4) Does your PC read the CC3200LAUNCHXL when you connect them via USB?
    5) Are you able to do run any of the SDK examples with your CC3200LAUNCHXL board?

    Please provide as much information/data as possible on your test environment and procedure.

    BR,
    Seong
  • In reply to Seong Kim:

    Hi Seong,

    Thanks for your reply, I have eventually got it to work after reformat, program the service pack and program the bin image file. I think I skipped the program service pack step, so that might have cause it to not work.

    Regards,

    Jet

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.