This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CC3200-LAUNCHXL: WLAN_STATION example not working

Intellectual 400 points

Replies: 23

Views: 535

Part Number: CC3200-LAUNCHXL

Hi

I have already gone through all the forums regarding this issue. But couldn't find any solution except that I should get the new board. WLAN_STATION example doesn't want to get connect to an AP . The red led keeps on blinking. I checked all parameters of my AP in common.h file. Everything seems fine. Do i have to update anything or its the problem with the hardware

Regards,

Charu

  • Expert 7245 points
    Hi Charu,

    I will try running the example and get back to you about my findings. In the mean time, please tell me what SDK and service pack you're using.

    Jesu
  • In reply to Jesu:

    Hi Jesu,

    I am using CC3100_CC3200_ServicePack_1.0.1.11-2.10.0.0 and CC3200SDK_1.3.0. And one more thing when I tried the serial wifi example I could connect to my AP  using local control mode.

    Regards,

    Charu

  • Expert 7245 points

    In reply to charusingh21:

    Hi Charu,

    It seems like you're stuck in the "waiting for connection loop" after the program calls sl_WlanConnect. This typically happens when users don't put the correct AP parameters. Please verify the parameters in the common.h file.

    Jesu
  • In reply to Jesu:

    I tried with 3 different AP's but again the same problem it doesn't want to connect..

  • Expert 7245 points

    In reply to charusingh21:

    Hi Charu,

    This is very odd. Could you tell me the rev (version) of the launchpad you're using and the full part number of the die?

    Jesu
  • In reply to Jesu:

    Hi Jesu,

    here are the launchpad details:

    MODEL: CC3200-LAUNCHXLA

    FCC ID: Z64-CC3200KITA

    IC ID:451I-CC3200KITA

    Regards,

    Charu

  • Expert 7245 points

    In reply to charusingh21:

    Hi Charu,

    We are using the same version launchpad. You have the correct service pack installed on device, latest SDK, you confirmed your AP configurations are correct. That is all that I did to get this example running.

    What AP are you using? Also, are you using secured network?

    Jesu
  • Expert 7245 points

    In reply to charusingh21:

    Hi Charu,

    I thought the IDs you provided indicate the part number your actual chip but it does not. I learned it has to do with certification. Anyway, could you answer my original question? I need the full part number of the die and the launchpad version.

    Jesu

  • In reply to Jesu:

    Hi Jesu,

    Part number: CC3200R1 M2

    Launchpad version: Rev 4.1

    Regards,

    Charu 

  • In reply to Jesu:

    Hi Jesu,
    Few days back everything worked fine . I was trying the wifi audio example but after i formatted it and then again flash the program it doesn't want to connect to the same AP . I tried using both open and WPA security. But this is strange to me that when I tried serial wifi example it does connect to the AP because we manually gave the command in local control mode that is wlan_connect [ssid] [type] [Sec] [User] [key]
    Regards,
    Charu

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.