This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

WL1837MOD: Need to call SetDevicePower(1) several times to power on BLE device

Prodigy 180 points

Replies: 4

Views: 81

Part Number: WL1837MOD

Hello TI support team,

It's VT from Vave Health. I am back on this problem because it's still not solved for me.

By reading the forum, I tried to replace TIInit_11.8.32.bts with TIInit_12.8.32.bts at the same location .../lib/firmware/.

When testing, I got this error:

Status: Executing BTS Script /lib/firmware/TIInit_11.8.32.bts.
Error: Could not open the script file /lib/firmware/TIInit_11.8.32.bts.

What do I need to do to execute TIInit_12.8.32.bts instead?

Thanks,

--VT

  • Hi VT,

    Have you copied the TIInit_11.8.32.bts to the /lib/firmware directory of your file system? If yes, can you double check the permissions for the file?

    You can find the latest version of WL18xx service pack (TIInit_11.8.32.bts) from the following page : WL18XX-BT-SP

    Best regards,

    Vihang

  • In reply to Vihang Parmar:

    Hi Vihang,

    Happy New Year!

    You misunderstood my question.

    I want to use TIInit_12.8.32.bts instead of TIInit_11.8.32.bts.

    What should I do?

    Thanks,

    --VT

  • In reply to VT Nguyen:

    Hi VT,

    The X, Y and Z version information in the TIinit_X.Y.Z.bts file are decided based on the ROM firmware version of your WL18xx chip. In your case, the TIinit_11.8.32.bts is required. You cannot use another version on this device. Please use the latest TIInit_11.8.32.bts. You can download it from the WL18XX-BT-SP page.

    Best regards,

    Vihang

  • In reply to Vihang Parmar:

    Ah ok, I see.

    Thank you for the info.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.