This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BOOSTXL-CC3135: MISO line stays low for any command

Part Number: BOOSTXL-CC3135
Other Parts Discussed in Thread: SEGGER, , UNIFLASH, CC31XXEMUBOOST


I have ported the simplelink driver to a host MCU, the nRF52840 on the nRF52840-DK, running Zephyr RTOS, using SEGGER Embedded Studio for ARM (Nordic Edition) V5.34a.

The HW connections are the following:
MISO -> P1.09
MOSI -> P0.30
CS -> P1.02
IRQ -> P1.03
CLK -> P0.31
nHIB -> P1.01

The BOOSTXL-CC3135 is powered by USB with the jumper J7 set to LDO.
I have disabled uart1 in order to use spi1 from the device tree using an overlay file.
The IRQ interrupt is set to rising edge, and is working.
All lines but MISO are working as expected.

The MISO line of the BOOSTXL-CC3135 always stays low. I have also tried to disconnect it from the nRF52840-DK and measured it during transfer - still 0V.
I have also tried to use another BOOSTXL-CC3135 and get the same results.
I have added log lines to the spi_Read and spi_Write called by the driver and it seems to always read 0x00 until I receive sync loss error.

The nRF52840 sends the SYNC sequence over SPI for any command: 0x21 0x43 0x34 0x12.
Additionally, I have updated the service pack of the BOOSTXL-CC3135 using the CC31XXEMUBOOST and UniFlash, with the same results before and after updating.

What are the possible causes of this?

Any help will be greatly appreciated.