This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CC2531EMK: CC2531 serial buffer overrun error when switches are operated at high frequency

Prodigy 30 points

Replies: 4

Views: 182

Part Number: CC2531EMK

I am using CC2531 as a zigbee dongle.I flashed it with this CC2531ZNP-Pro-Secure_Standard.hex.  I am using zigbee home automation switches.

I have configured these switches on openhab.And I can control zigbee swiches from openhab ui.

Issue is that if i operate switches from openhab ui at high frequency .ie. (turn on the switch and immediately turn of the switch)switches respond very late with this log

  --- [ding.zigbee.zigbee serial port] - processing data available event: zigbee serial

   buffer overrun

Please help me with this issue.

  • Hi Rakesh,

    Try increasing the baud rate to the maximum value of 115200.  You will need to contact openHAB for questions concerning their interface.  There is nothing to investigate from TI's perspective since this project uses a Z-STACK-ARCHIVE project with the recommended CC2531 image.

    Regards,
    Ryan

    To better aid the community, please click on the "This Resolved my issue" button whenever a post answers your question!

  • In reply to Ryan Brown1:

    I raised issue on openhab forum regarding this serial buffer overrun.They have replied that it is some serial issue of cc2531.

    I am stuck at this.

    What is the default baud rate of cc2531?

    What can cause serial issue with the dongle?

  • In reply to Rakesh Kolage:

    Can you provide a link to your openHAB forum post?  The default baud rate is 38400 but can be modified in the ZNP IAR project, although this would require you to re-flash the USB dongle with a CC-DEBUGGER.  Based on your description, I would imagine that a buffer overflow is causing the problem.

    Regards,
    Ryan

    To better aid the community, please click on the "This Resolved my issue" button whenever a post answers your question!

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.