This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC2531: Not able to configure reporting of a smoke alarm ZED

Part Number: CC2531

Hi All,

I have a CC2531 connected to a TIVA microcontroller via UART.

Basically, this CC2531 act as the ZigBee Coordinator and TIVA as the host processor.

I could bind and configure the reporting of temperature and humidity ZED sensor successfully. And then I tried to bind and configure the reporting of a smoke alarm ZED also.

Binding of smoke alarm ZED was successful. I could see (using Ubiqua Protocol Analyzer) that the smoke alarm ZED responded with success status. 

And then after binding the smoke alarm ZED, the host processor sent the configure reporting command (as shown below). Unfortunately, the smoke alarm ZED did not respond with anything.

I expect that the smoke alarm ZED responded with success status but no respond at all. And smoke alarm ZED did not report its status at all to ZC.

Maybe my configure reporting command is not correct. Can you please check my configure reporting command? Or maybe I'm missing some steps. Please let me know.

Configure reporting: In the CommandId part, I tried the 0x0001 (power configuration) and 0x0402 too but no success.

Length = 0x15
Cmd0 = 0x26
Cmd1 = 0x03
Destination = 0xEB04 (end-device short address)
CommandId = 0x0500 (IAS Zone)
Handle = 0x22
Ack 0x01
Radius = 0x0f
Len = 0x0d
framecontrol-1Byte = 0x00
transID-1Byte = 0x00
commandID-1Byte = 0x06 (configure reporting)
Direction-1Byte = 0x00
AttributeIdentifier-2Bytes = 0x0000
AttributeDataType-1Byte = 0x29
MinReportingInterval-2Bytes = 0x0028
MaxReportingInterval-2Bytes = 0x0032
ReportableChange-Variable) = 0x0032
Tx: 0xfe 0x15 0x26 0x03 0x04 0xEB 0x00 0x05 0x16 0x01 0x0f 0x0d 0x00 0x00 0x06 0x00 0x00 0x00 0x29 0x28 0x00 0x32 0x00 0x32 0x00 FCS

Thank you.