This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC2652P: CC2652P ZNP stops working after being operational around 1 year.

Guru 14805 points
Part Number: CC2652P

Hello All,

 I am using CC2652P & simplink sdk v5.20 based ZNP along for Raspberry pi over UART and zigbee 3.0 linux gateway. 

The Gateway has stopped working after being operational for around 1 year. 

here is  the details/log when we start - ./zigbeeHAGW service  - 

------------------------------------------------------------------------------------------------------------------

Platform type selected automatically as bbb.
To override this selection, please stop this script, and then run it again,
specifying the desired platform type at the command line:
./zigbeeHAgw [help | bbb | x86 ]

running ./zigbeeHAgw on an ARM
done processing arguments, board type bbb, target arm
NPI is 'NPI_lnx_arm_server'
Zstack linux server is 'ZLSZNP_arm'
gateway server is 'GATEWAY_SRVR_arm'
network manager is 'NWKMGR_SRVR_arm'
OTA server is 'OTA_SRVR_arm'
Starting the ZigBee gateway subsystem
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 0 NWKMGR servers
there are 0 OTA servers
(total 0)
done
===================================================
starting NPI, cmd ' ./NPI_lnx_arm_server NPI_Gateway.cfg ' on Sat 25 Feb 11:55:22 IST 2023
[11:55:22.913,762] [NPISRVR/MAIN] UNMSKBL:
[11:55:22.914,012] [NPISRVR/MAIN] UNMSKBL: ************************************************
[11:55:22.914,033] [NPISRVR/MAIN] UNMSKBL: * NPI Server v1.0.2d *
[11:55:22.914,046] [NPISRVR/MAIN] UNMSKBL: ************************************************
[11:55:22.914,057] [NPISRVR/MAIN] UNMSKBL:
getaddrinfo error: Servname not supported for ai_socktype
Startup phase 1 completed successfully, server started (NPI_PID=5787) on Sat 25 Feb 11:55:22 IST 2023
===================================================
starting ZLSZNP, cmd ' ' on Sat 25 Feb 11:55:22 IST 2023
[11:55:22.933,233] [Z_STACK/MAIN] UNMSKBL:
[11:55:22.933,376] [Z_STACK/MAIN] UNMSKBL: ************************************************
[11:55:22.933,395] [Z_STACK/MAIN] UNMSKBL: * ZStack Server for ZNP v1.0.2d *
[11:55:22.933,407] [Z_STACK/MAIN] UNMSKBL: ************************************************
[11:55:22.933,447] [Z_STACK/MAIN] UNMSKBL:
[11:55:24.933,756] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[11:55:24.933,802] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[11:55:26.933,996] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[11:55:26.934,052] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[11:55:28.934,312] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[11:55:28.934,405] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[11:55:30.934,679] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[11:55:30.934,756] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
^Ccaught SIGTERM, killing all the servers and cleaning up
waiting for NPI to exit
recv: Connection reset by peer
making sure there are no lingering servers...
there are 0 NPI servers
there are 1 ZLS servers
there are 0 GATEWAY servers
there are 0 NWKMGR servers
there are 0 OTA servers
(total 1)
^C^C./zigbeeHAgw: line 560: 0 + 0 + 0 + 0 + : syntax error: operand expected (error token is "+ ")
Startup phase 2 failed
making sure there are no lingering servers...
^Ccaught SIGTERM, killing all the servers and cleaning up
making sure there are no lingering servers...
^C./zigbeeHAgw: line 560: 0 + 0 + 0 + 0 + : syntax error: operand expected (error token is "+ ")
./zigbeeHAgw: line 560: 0 + 0 + 0 + 0 + : syntax error: operand expected (error token is "+ ")
waiting for netmgr to exit ( pid 0 ) on Sat 25 Feb 11:55:31 IST 2023
./zigbeeHAgw: line 998: wait: pid 0 is not a child of this shell
oops! Network manager has already exited (!) on Sat 25 Feb 11:55:31 IST 2023
I am killing myself will not take further action
./zigbeeHAgw exiting
^Ccaught SIGTERM, killing all the servers and cleaning up
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 0 NWKMGR servers
there are 0 OTA servers
(total 0)
done
terminating zigbeeHAGW (pid 5650)
Killed
Db50Gw@ftzbgw:~/zigbee_gateway_v3.0/out/Precompiled/servers $ clrscreen
bash: clrscreen: command not found
Db50Gw@ftzbgw:~/zigbee_gateway_v3.0/out/Precompiled/servers $ ./zigbeeHAgw
set gpio 22 mode
set gpio 22 low
set gpio 22 high
start gateway
./zigbeeHAgw: line 56: l: command not found
Platform type selected automatically as bbb.
To override this selection, please stop this script, and then run it again,
specifying the desired platform type at the command line:
./zigbeeHAgw [help | bbb | x86 ]

running ./zigbeeHAgw on an ARM
done processing arguments, board type bbb, target arm
NPI is 'NPI_lnx_arm_server'
Zstack linux server is 'ZLSZNP_arm'
gateway server is 'GATEWAY_SRVR_arm'
network manager is 'NWKMGR_SRVR_arm'
OTA server is 'OTA_SRVR_arm'
Starting the ZigBee gateway subsystem
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 0 NWKMGR servers
there are 0 OTA servers
(total 0)
done
===================================================
starting NPI, cmd ' ./NPI_lnx_arm_server NPI_Gateway.cfg ' on Sat 25 Feb 12:05:19 IST 2023
[12:05:19.068,901] [NPISRVR/MAIN] UNMSKBL:
[12:05:19.069,287] [NPISRVR/MAIN] UNMSKBL: ************************************************
[12:05:19.069,320] [NPISRVR/MAIN] UNMSKBL: * NPI Server v1.0.2d *
[12:05:19.069,346] [NPISRVR/MAIN] UNMSKBL: ************************************************
[12:05:19.069,369] [NPISRVR/MAIN] UNMSKBL:
getaddrinfo error: Servname not supported for ai_socktype
Startup phase 1 completed successfully, server started (NPI_PID=7789) on Sat 25 Feb 12:05:19 IST 2023
===================================================
starting ZLSZNP, cmd ' ' on Sat 25 Feb 12:05:19 IST 2023
[12:05:19.108,182] [Z_STACK/MAIN] UNMSKBL:
[12:05:19.108,430] [Z_STACK/MAIN] UNMSKBL: ************************************************
[12:05:19.108,463] [Z_STACK/MAIN] UNMSKBL: * ZStack Server for ZNP v1.0.2d *
[12:05:19.108,488] [Z_STACK/MAIN] UNMSKBL: ************************************************
[12:05:19.108,511] [Z_STACK/MAIN] UNMSKBL:
[12:05:21.108,905] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:21.108,977] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:23.109,240] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:23.109,299] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:25.109,530] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:25.109,593] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:27.109,928] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:27.110,021] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:29.110,284] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:29.110,331] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:31.110,527] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:31.110,614] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:33.110,903] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:33.110,989] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:35.111,279] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:35.111,367] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:37.111,658] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:37.111,751] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
Startup phase 2 completed successfully, server started (ZLSZNP_PID=7795) on Sat 25 Feb 12:05:37 IST 2023
===================================================
starting NETWORK_MGR, cmd ' ./NWKMGR_SRVR_arm 127.0.0.1:2536 ' on Sat 25 Feb 12:05:37 IST 2023
[12:05:37.163,820] [NWK_MGR/MAIN] UNMSKBL:
[12:05:37.164,180] [NWK_MGR/MAIN] UNMSKBL: ************************************************
[12:05:37.164,216] [NWK_MGR/MAIN] UNMSKBL: * Network Manager Server v1.0.2d *
[12:05:37.164,245] [NWK_MGR/MAIN] UNMSKBL: ************************************************
[12:05:37.164,271] [NWK_MGR/MAIN] UNMSKBL:
[12:05:39.113,829] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:39.113,928] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:39.169,818] [NWK_MGR/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:39.169,912] [NWK_MGR/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:39.170,102] [NWK_MGR/MAIN] ERROR : ERROR: signal 11 was trigerred:
[12:05:39.170,156] [NWK_MGR/MAIN] ERROR : Fault address: (nil)
[12:05:39.170,202] [NWK_MGR/MAIN] ERROR : Fault reason: address not mapped to object
[12:05:39.171,091] [NWK_MGR/MAIN] ERROR : Stack trace unavailable
[12:05:39.171,167] [NWK_MGR/MAIN] ERROR : Executing original handler...
Startup phase 3 failed
waiting for Zstack linux to exit
waiting for NPI to exit
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 0 NWKMGR servers
there are 0 OTA servers
(total 0)
done
Executing reset from external scripts
===================================================
starting NPI, cmd ' ./NPI_lnx_arm_server NPI_Gateway.cfg ' on Sat 25 Feb 12:05:43 IST 2023
[12:05:43.531,831] [NPISRVR/MAIN] UNMSKBL:
[12:05:43.532,529] [NPISRVR/MAIN] UNMSKBL: ************************************************
[12:05:43.532,573] [NPISRVR/MAIN] UNMSKBL: * NPI Server v1.0.2d *
[12:05:43.532,625] [NPISRVR/MAIN] UNMSKBL: ************************************************
[12:05:43.532,656] [NPISRVR/MAIN] UNMSKBL:
getaddrinfo error: Servname not supported for ai_socktype
Startup phase 1 completed successfully, server started (NPI_PID=7899) on Sat 25 Feb 12:05:43 IST 2023
===================================================
starting ZLSZNP, cmd ' ' on Sat 25 Feb 12:05:43 IST 2023
[12:05:43.577,785] [Z_STACK/MAIN] UNMSKBL:
[12:05:43.578,098] [Z_STACK/MAIN] UNMSKBL: ************************************************
[12:05:43.578,137] [Z_STACK/MAIN] UNMSKBL: * ZStack Server for ZNP v1.0.2d *
[12:05:43.578,168] [Z_STACK/MAIN] UNMSKBL: ************************************************
[12:05:43.578,200] [Z_STACK/MAIN] UNMSKBL:
[12:05:45.578,942] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:45.578,996] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:47.579,198] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:47.579,277] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:49.579,536] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:49.579,615] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:51.579,907] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:51.579,970] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:53.580,165] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:53.580,242] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:55.580,495] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:55.580,569] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:57.580,954] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:57.581,001] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:05:59.581,190] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:05:59.581,266] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:01.581,571] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:01.581,624] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
Startup phase 2 completed successfully, server started (ZLSZNP_PID=7905) on Sat 25 Feb 12:06:01 IST 2023
===================================================
starting NETWORK_MGR, cmd ' ./NWKMGR_SRVR_arm 127.0.0.1:2536 ' on Sat 25 Feb 12:06:01 IST 2023
[12:06:01.603,132] [NWK_MGR/MAIN] UNMSKBL:
[12:06:01.603,747] [NWK_MGR/MAIN] UNMSKBL: ************************************************
[12:06:01.603,764] [NWK_MGR/MAIN] UNMSKBL: * Network Manager Server v1.0.2d *
[12:06:01.603,778] [NWK_MGR/MAIN] UNMSKBL: ************************************************
[12:06:01.603,789] [NWK_MGR/MAIN] UNMSKBL:
[12:06:03.582,686] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:03.582,741] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:03.605,746] [NWK_MGR/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:03.605,962] [NWK_MGR/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:03.606,065] [NWK_MGR/MAIN] ERROR : ERROR: signal 11 was trigerred:
[12:06:03.606,088] [NWK_MGR/MAIN] ERROR : Fault address: (nil)
[12:06:03.606,100] [NWK_MGR/MAIN] ERROR : Fault reason: address not mapped to object
[12:06:03.606,504] [NWK_MGR/MAIN] ERROR : Stack trace unavailable
[12:06:03.606,539] [NWK_MGR/MAIN] ERROR : Executing original handler...
Startup phase 3 failed
waiting for Zstack linux to exit
waiting for NPI to exit
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 0 NWKMGR servers
there are 0 OTA servers
(total 0)
done
Executing reset from external scripts
===================================================
starting NPI, cmd ' ./NPI_lnx_arm_server NPI_Gateway.cfg ' on Sat 25 Feb 12:06:07 IST 2023
[12:06:07.883,356] [NPISRVR/MAIN] UNMSKBL:
[12:06:07.883,752] [NPISRVR/MAIN] UNMSKBL: ************************************************
[12:06:07.883,783] [NPISRVR/MAIN] UNMSKBL: * NPI Server v1.0.2d *
[12:06:07.883,812] [NPISRVR/MAIN] UNMSKBL: ************************************************
[12:06:07.883,835] [NPISRVR/MAIN] UNMSKBL:
getaddrinfo error: Servname not supported for ai_socktype
Startup phase 1 completed successfully, server started (NPI_PID=8009) on Sat 25 Feb 12:06:07 IST 2023
===================================================
starting ZLSZNP, cmd ' ' on Sat 25 Feb 12:06:07 IST 2023
[12:06:07.937,669] [Z_STACK/MAIN] UNMSKBL:
[12:06:07.938,043] [Z_STACK/MAIN] UNMSKBL: ************************************************
[12:06:07.938,076] [Z_STACK/MAIN] UNMSKBL: * ZStack Server for ZNP v1.0.2d *
[12:06:07.938,102] [Z_STACK/MAIN] UNMSKBL: ************************************************
[12:06:07.938,126] [Z_STACK/MAIN] UNMSKBL:
[12:06:09.939,051] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:09.939,132] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:11.939,416] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:11.939,499] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:13.939,792] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:13.939,876] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:15.940,159] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:15.940,237] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:17.940,493] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:17.940,582] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:19.941,025] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:19.941,073] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:21.941,320] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:21.941,399] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:23.941,655] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:23.941,733] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:25.941,988] [Z_STACK/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:25.942,039] [Z_STACK/MAIN] ERROR : apicSendSynchData() failed getting response
Startup phase 2 completed successfully, server started (ZLSZNP_PID=8015) on Sat 25 Feb 12:06:25 IST 2023
===================================================
starting NETWORK_MGR, cmd ' ./NWKMGR_SRVR_arm 127.0.0.1:2536 ' on Sat 25 Feb 12:06:25 IST 2023
[12:06:25.961,270] [NWK_MGR/MAIN] UNMSKBL:
[12:06:25.961,476] [NWK_MGR/MAIN] UNMSKBL: ************************************************
[12:06:25.961,491] [NWK_MGR/MAIN] UNMSKBL: * Network Manager Server v1.0.2d *
[12:06:25.961,504] [NWK_MGR/MAIN] UNMSKBL: ************************************************
[12:06:25.961,515] [NWK_MGR/MAIN] UNMSKBL:
^Ccaught SIGTERM, killing all the servers and cleaning up
waiting for Zstack linux to exit
waiting for NPI to exit
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 1 NWKMGR servers
there are 0 OTA servers
(total 1)
^C^C./zigbeeHAgw: line 571: 0 + 0 + 0 + 1 + : syntax error: operand expected (error token is "+ ")
Startup phase 3 failed
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 1 NWKMGR servers
there are 0 OTA servers
(total 1)
[12:06:27.963,233] [NWK_MGR/MAIN] ERROR : SRSP Cond Wait timed out!
[12:06:27.963,280] [NWK_MGR/MAIN] ERROR : apicSendSynchData() failed getting response
[12:06:27.963,384] [NWK_MGR/MAIN] ERROR : ERROR: signal 11 was trigerred:
[12:06:27.963,404] [NWK_MGR/MAIN] ERROR : Fault address: (nil)
[12:06:27.963,422] [NWK_MGR/MAIN] ERROR : Fault reason: address not mapped to object
[12:06:27.963,829] [NWK_MGR/MAIN] ERROR : Stack trace unavailable
[12:06:27.963,863] [NWK_MGR/MAIN] ERROR : Executing original handler...
^Ccaught SIGTERM, killing all the servers and cleaning up
making sure there are no lingering servers...
there are 0 NPI servers
there are 0 ZLS servers
there are 0 GATEWAY servers
there are 0 NWKMGR servers
there are 0 OTA servers
(total 0)
done
terminating zigbeeHAGW (pid 7638)
Killed

------------------------------------------------------------------------------------------

How can I troubleshoot further, any suggestions plz.

Thanks

Dhanraj