This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC2630: ZNP: the host and znp stack SW cannot connected via UART

Part Number: CC2630
Other Parts Discussed in Thread: Z-STACK

hi,

My system is one ARM mainboard and one CC2630 chip, they are connected via uart (ttymxc1).  I am using sw ZNP and host test sw to test them. but the problem it seams that the communication is not, please help to point whether there is sth wrong? 

By the way, I have already download the C:\ti\simplelink\zstack_home_1_02_02a_44539\Projects\zstack\ZAP\ZNP-HexFiles\CC26xx\znp_coordinator_pro.hex into the cc2630 chip via smartRFtool _flash_programmer 2 via TI XDS.  And I am sure the download is OK.

the configuration of UART and logs are as following:

root@DESBase:~# uname -a
Linux DESBase 4.14.98-ga3f8563-dirty #16 SMP PREEMPT Wed Feb 19 17:46:52 CST 2020 armv7l armv7l armv7l GNU/Linux
root@DESBase:~# pwd
/home/root
root@DESBase:~# cd znp-host-framework/
root@DESBase:~/znp-host-framework# ls
README.MD build_znp_host.sh examples stressTest.bin
README.html cmdLine.bin framework
ZNP host SW framework_1.0.0_manifest.html dataSendRcv.bin nwkTopology.bin
bin docs servDisc.bin
root@DESBase:~/znp-host-framework# stty -F /dev/ttymxc1 -a
speed 9600 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>;
start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; discard = ^O;
min = 1; time = 0;
-parenb -parodd -cmspar cs8 hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel
-iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke -flusho
-extproc
root@DESBase:~/znp-host-framework#
root@DESBase:~/znp-host-framework# ./cmdLine.bin /dev/ttymxc1 

./cmdLine.bin -- Mar 16 2020 03:52:04
rpcWaitMqClientMsg: timeout=10
rpcWaitMqClientMsg: waiting on queue 10:1550694526:10000000
rpcWaitMqClientMsg: Timed out [-1] - Connection timed out
flushed 0 message from msg queue
creating RPC thread
creating example thread
rpcWaitMqClientMsg: timeout=50
rpcWaitMqClientMsg: waiting on queue 50:1550694526:50000000
rpcWaitMqClientMsg: Timed out [-1] - Connection timed out
Do you wish to start/join a new network? (y/n)
y
rpcSendFrame: Blocking on RPC sem
rpcSendFrame: Sending RPC
rpcTransportWrite : len = 10
writing 8 bytes (offset = 0, remain = 10)
writing 2 bytes (offset = 8, remain = 2)
SOC OUT --> 10 Bytes: SOF:FE, Len:05, CMD0:21, CMD1:09, Payload:03:00:00:01:03, FCS:2C
rpcSendFrame: waiting for SRSP [01]
rpcSendFrame: SRSP Error - CMD0: 0x21 CMD1: 0x09

NV Write Startup Option cmd sent[1]...
network start failed
Network Error

rpcSendFrame: Blocking on RPC sem
rpcSendFrame: Sending RPC
rpcTransportWrite : len = 5
writing 5 bytes (offset = 0, remain = 5)
SOC OUT --> 5 Bytes: SOF:FE, Len:00, CMD0:21, CMD1:04, Payload: FCS:25
rpcSendFrame: waiting for SRSP [01]
rpcSendFrame: SRSP Error - CMD0: 0x21 CMD1: 0x04
rpcSendFrame: Blocking on RPC sem
rpcSendFrame: Sending RPC
rpcTransportWrite : len = 10
writing 8 bytes (offset = 0, remain = 10)
writing 2 bytes (offset = 8, remain = 2)
SOC OUT --> 10 Bytes: SOF:FE, Len:05, CMD0:21, CMD1:09, Payload:8F:00:00:01:01, FCS:A2
rpcSendFrame: waiting for SRSP [01]
rpcSendFrame: SRSP Error - CMD0: 0x21 CMD1: 0x09
Enter CMD

brgs,

chi xiaobo