This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADS8861: EVM-PDK "Problem starting libusb0.dll" leads to ADCPro not working

Part Number: ADS8861
Other Parts Discussed in Thread: ADCPRO,

While installing the ADC Pro Plugin "ads886x-adcproplugin-1.0.1.exe" I run into an error while installing the LibUsb drivers v1.2.6. At a certain point I get 

"There was a problem starting libusb0.dll

The specified module could not be found."

When I hit ok it still completes the installation, but when I open ADCPro and select ADS886xEVM it goes through its startup messages in the top left then when it gets to firmware downloading it gets hung up on "Download failed..reset the hardware" and eventually times out.

I've checked the jumpers on board and they look right. I'm running Windows 10.



  • We are looking into this problem to find the smoothest way to install this software on your Windows 10 machine. In parallel, we are working towards preventing future difficulties like this one.
  • Kevin:

    After some investigation, I believe the issue is related to driver signing.  Previous versions of Windows would prompt the user with a warning that the driver is not signed, and would you like to install it anyway; Windows 10 simply does not install an unsigned driver.  On my machine, I installed the ADCPro software with the ADS8861 Plugin, and got the same message that you did.  

    However, there is a work-around that should get you going.  To do this, you may need to uninstall ADCPro, the Plugin, and also the MMB0 drivers from the Control Panel.  After fully removing the software:

    1. Restart Windows 10 with advanced boot options by holding the SHIFT key while clicking Restart.

    2. When the system comes up, select the Troubleshoot option, then Advanced Options, then Startup Settings.  Click Restart.

    3. When the system comes up again, select option 7, "Disable Driver Signature Enforcement".  Restart again.

    4. Install the MMB0 driver, then ADCPro, then the plugin.  

    After restarting your machine again, driver signature enforcement should re-enable itself.

    In parallel, our software team is in the process of adding the necessary digital signatures to the driver software, so that we do not keep having this issue.

  • Ah yes that old trick :) I've had to do that before with some other software.

    It worked though! Thanks for your help.

  • Dear Kevin,

    I am trying to install on "windows 7" OS. Facing the same problem "Download failed..reset the hardware" and eventually times out.

    Jumper settings are fine.

  • Santosh:

    Your issue seems like a different problem, although the error message you are getting does seem to indicate that the hardware drivers are not properly installed. The issue above was a Windows 10 issue, but you are installing on Windows 7. Windows 7 probably pops a message box up that asks permission to install the drivers, and if that is the case, you need to answer "Yes." Or you may need to run the "Setup" program by right-clicking and selecting "Run As Administrator" to give it the proper permissions.

    Are you still having this issue?