This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

My MSP432 is drawing 170 mA. Why?

Other Parts Discussed in Thread: ENERGYTRACE, MSP432P401R, MSPWARE

Hi.

I got MSP432 launchpad a week ago.

Studying MSP430 LaunchPad Workshop Course Workbook as my textbook. There was no problem whatsoever. But in lab 7(Energy trace) I've encountered a problem.

After flashing solution of lab_07b_lpm_timer project. I ran EnergyTrace. But EnergyTrace immediately stops and it says "Target current exceeded with the maximum current (75mA) supported by EnergyTrace."

Huh?

So I actually measured current and voltage with my multimeters and the uc was drawing 170 mA. Even in the reset state.

No external circuitry has ever connected to my launchpad. Even no single jumper wire.

What could be a cause of this problem? ESD?

-----------------------------------------------------------------------------------

Sep. 3,

Planning to get another MSP432 LaunchPad and MSP432P401RIPZ(LQFP100) next week.

I will update this post after replacing MSP432 chip on this LaunchPad board.

Thanks to everyone who cared about my problem.

-----------------------------------------------------------------------------------

Sep. 10,

Replaced old MSP432 with the new one. It turns out that the MSP432 was the problem. After replacing, current consumption of the board drop to 1.5 uA, with debugger connected and all default jumpers connected. Very happy with it.

  • What happens if you flash another (already tested) program onto the processor and where did you measure the current/voltage?
  • Hello Dennis.

    After reading your reply I flashed few verified programs to MSP432 and ran them.

    lab_02a: "hello world" via debug CCS console. - Works: hello world is printed -
    lab_02b: blink led using gpio and software delay. - Works: LED binks-
    lab_06c: Timer directly drives Led, also utilising port map. - Works: LED blinks -

    Few more measurements:
    While 3V3 Jumper disconnected. 3V3 from XDS110-ET was 3.29 V
    While 3V3 Jumper is connected. 3V3 from XDS110-ET was 3.23 V (voltage drop due to 170 mA current draw maybe)
    While Blinking Blue LED on P2.2:
    Port output high voltage: 3.00 V
    Port output low voltage: 0.01 V

    So debug module, GPIO and timer works. Still, in every case current draw is measured about 170 mA. (pretty constant, only goes up few mA when LED turns on)
  • Do you measure the current by removing the 3.3V jumper and hooking your probes to it?

    Did you double check if all other jumpers are in the correct position? For example the three LED jumpers? Maybe inserted 90 degrees to the normal position and shorting two outputs of the MSP?

  • Yes. I used that header pins for the measurement.

    This is my measurement setup. lab_06c: Timer directly drives LED is running.

    Left meter: measuring current in Amps range.

    Right meter: measuring voltage of 3v3 rail.

    No 90º jumpers.

    FYI. surface temperature of the MSP432 chip was about 52 ℃ (126℉). delta T ≈ +29 ℃

  • Seungwon,
    170mA is definitely too high, more than maximum current draw specified on the MSP432P401R. Can you do a couple of experiments:
    - In one of your LED examples, after verifying that the code works, remove all LED jumpers. Does the current still read 170mA?
    - Try out this LPM3 code example dev.ti.com/tirex , which ideally should put the device down to LPM3, consuming only 850nA. If you still read several mA of current at this point, most likely we're looking at a short somewhere on the board.
    ~Dung
  • Dung,

    Sure.

    I did experiments you said.

    Not pictured but removing jumpers while running blink program did not affected to current readings. Just LED current fluctuations are gone. Still around 170 mA.

    I imported LPM3 example to my workspace and flashed to MSP432. Example from "MSPWare: msp432p401_pcm_02 Enter LPM3 (ARM Deep Sleep Mode) with ACLK = REFO"
    Also every jumpers are removed.

    Curiously entering LPM3 drew more current. it's 190 mA now.

    While pressing reset button 170 mA.

    Video:

  • Hi Seungwon,

      Have you tried using an external power supply?? Please power the board thru J6.

    Also please make sure that you movethe switch to Ext Debug and remove all the jumpers on the board especially these:

    Do you still see the 190mA??

     Regards,

      David

  • Hi David,

    Powering with external power supply didn't make big difference. Current slightly increased but minor. (Running LPM3 MSPWare example)

    Also while in reset state,

    Current during reset state should be around 1 mA referring to device datasheet. Hmm...

  • Hi Seungwon,

    Do you have access to an infrared thermometer with dual-laser spot indicator? Or even better to an IR-Camera?
    You can search for hot spots on the PCB, to investigate the path of the flowing current. I just want to make sure it's not a decoupling cap or something else that has a malfunction.

    ESD can be one source of damage for sure.

    Kind regards,
    Sebastian
  • When pressing the reset button while still having this high current, I would also suspect that a) a semiconductor is damaged, b) like Sebastian said, there is a faulty component or c) somewhere is a small solder short.
  • Hi Sebastian,

    I don't have access to professional thermal imaging cameras. Instead I have small smartphone attachable thermal camera. - Seek Compact XR from Seek Thermal, Inc.
    Resolution is not that high, manual focus, no colorbar, app has some bugs, but kinda works.

    Condition: Same as before
    Again, LPM3 example program.
    3.3 V Externally powered through J6.
    All jumpers removed.
    Set JTAG selection switch to external.

    0:03 Power on - 197 mA @ 3.27 V
    3:04 Close up board inspection
    3:56 Power off

    No external sign of short. Hmm.

    Definitely some kind of bad things happened to the silicon in my chip as Dennis said.

    Thanks,

    Seungwon

  • Hi Seungwon,

    wow, good job! That was exactly what I was talking about. What you can see are the parts with the bigest current density, obviously the MSP, but the root cause can be external, i.e. shorted GPIOs. As the lines on the PCB are pretty wide they don't tend to heat up as much because the current density is less and also thermal disipation is greater.
    At least you probably can exclude other components or ICs on the PCB, as the MSP was the hotest one.
    Can you change the MSP with a new one?

    Kind regards,
    Sebastian
  • WOW! That comes from a smartphone?! It is great!

    But desoldering the MSP from the LaunchPad isn't worth the effort, I guess :-\

  • Yup. Planning to get a new MSP and replace this one.
    I 'll update my post after replacing this MSP with a new one. :-)

    Thanks,
    Seungwon
  • Agreed. Getting a new LaunchPad is more time saving.
    But I just want to make sure which one is causing this current consumption, the board or the MSP?
    :D
  • I'm sending you a PM to get your address information to send you a new unit. I will also send you a prepaid label to ship your current unit back to me for evaluation.

  • That is great, ! Thumbs up!
  • Hi Mike,


    I really appreciate your offer. But I already ordered both LaunchPad and MSP432 from TI store on Sep. 2.. Expected delivery date is next monday.

    Thanks,
    Seungwon

  • Anyone encounters the same problem? I am seeing about 190mA too, but i can still program and the MCU still work. 

  • Hi,

    can you please check if you considered PORT31 ERRATA mentioned in the ERRATA sheet:

    Best regards,
    Dietmar

**Attention** This is a public forum