This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/CC2650: Memory write failed: Timed out waiting for target to halt

Part Number: CC2650

Tool/software: Code Composer Studio

I'm just getting up to speed on the CC2650 and CCS, so please excuse me if this has been answered already.

I'm having a horrible experience with this whole endeavour. I'm working on a Mac, but I've also tried to get around this issue on Windows 10 as well.

CCS V7.0. CC2650 LaunchPad.

I started with project zero from resource explorer. everything went well.

Using the PWM LED sample code out of the resource explorer. I was able to compile, load, run, and modify the code about a dozen times.

Little by little, my board got a timeout, but reflashing it got me through. Then it would simply timeout and never write again.

I noticed that there is a version 7.1 out, no difference. So I loaded the last of the V6 era, no difference.

I grabbed our customer's SmartRF06 board, first attempt using a resource explorer demo program succeeded. Second attempt, and the board is borked. Same timeout problem.

So I go back to my LaunchPad, because I obviously don't know what I'm doing. Blow everything away, CCS, TI directory in home directory, and workspace, reinstall, and restart my computer. Same result.

Cortex_M3_0: GEL Output: Memory Map Initialization Complete.

Cortex_M3_0: GEL Output: Board Reset Complete.

Cortex_M3_0: File Loader: Memory write failed: Timed out waiting for target to halt

Cortex_M3_0: GEL: File: /Users/andreichichak/workspace_v6_2/pwmled_CC2650_LAUNCHXL_TI/Debug/pwmled_CC2650_LAUNCHXL_TI.out: Load failed.

So I go into the project properties, general, verify that the connection is correct, and click on Verify..., and I get:


Execute the command:

%ccs_base%/common/uscif/dbgjtag -f %boarddatafile% -rv -o -S integrity


-----[Print the board config pathname(s)]------------------------------------


-----[Print the reset-command software log-file]-----------------------------

This utility has selected a 100- or 510-class product.
This utility will load the adapter 'libjioxds110.dylib'.
The library build date was 'Feb 22 2017'.
The library build time was '17:01:28'.
The library package version is '6.0.579.0'.
The library component version is ''.
The controller does not use a programmable FPGA.
The controller has a version number of '5' (0x00000005).
The controller has an insertion length of '0' (0x00000000).
This utility will attempt to reset the controller.
This utility has successfully reset the controller.

-----[Print the reset-command hardware log-file]-----------------------------

The scan-path will be reset by toggling the JTAG TRST signal.
The controller is the XDS110 with USB interface.
The link from controller to target is direct (without cable).
The software is configured for XDS110 features.
The controller cannot monitor the value on the EMU[0] pin.
The controller cannot monitor the value on the EMU[1] pin.
The controller cannot control the timing on output pins.
The controller cannot control the timing on input pins.
The scan-path link-delay has been set to exactly '0' (0x0000).

-----[An error has occurred and this utility has aborted]--------------------

This error is generated by TI's USCIF driver or utilities.

The value is '-230' (0xffffff1a).
The title is 'SC_ERR_PATH_MEASURE'.

The explanation is:
The measured lengths of the JTAG IR and DR scan-paths are invalid.
This indicates that an error exists in the link-delay or scan-path.


Sorry if I don't grok the tool specific jargon, but it doesn't point to a solution.

Does anybody have an idea how to unwedge these processors?



  • I believe I found a work around.

    Under Windows, grab a copy of SmartRF Flash Programmer 2. Use it to erase your processor and you can now download code.

    I've used this on two processors now. I have no idea how they managed to get messed up, but it seems to be very easy to do so, and this will straighten them out.