This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/CC1350STK: Empty project debug session not as expected

Part Number: CC1350STK
Other Parts Discussed in Thread: LAUNCHXL-CC2640R2, CC13XXWARE, CC2650STK

Tool/software: Code Composer Studio

Hi

CCS 9.1 Linux MInt 18

CC1350STK and empty_min_CC1350STK_TI

The project is supposed to blink a LED, but nothing happens. Also right after launching a debug session, the target is running and doesn't stop at main (although this is checked in debug settings that I haven't modified ).

Here is the screen shot after having clickec on the Bug icon of said project that I haven't modified (including the target configuration):

thanks

Peter

  • Hi Peter,

    I just tried the Empty example found in CC13x0 SDK 2.20.00.23 in CCS 9.1 (Windows 10, I do not have Linux Mint 18). The project build and when I launch a debug session on a CC1350SDK it stops at main and when I press resume the LED start blinking. 

    What SDK are you using?

    Best Regards,

    R.M

  • Hi R.M.

    First, to answer your question, here is a screen shot:

    2) I noticed that I started the wrong project when I opened the ticket.

    What seems to happen in CCS is this:

    - I have an active project A (name in bold in the project explorer)

    - I select another project B (name becomes bold) and I start a debug session

    - the debug session fails and I am returned to the Edit Perspective

    - interestingly the previous project A is again the active one.

    Can you verify this behavior on CCS  Version: 9.1.0.00010 ?

    3) I now have a working debug session and the LED blinks, but only after I modified the target conf file and the debug configuration (Target tab):

    Here are the original settings that came with the empty project:

    The target configuration:

    And the debug configuration:

    These didn't work for me.

    Here is what seems to work:

    Target conf:

    Debug conf:

    Could you share the recommend settings / your settings with me ?


    Kind regards

    Peter

  • Hi Peter,

    1. It looks like you are using an quite old SDK version. Can you try to upgrade to the latest SDK that can be found here: http://www.ti.com/tool/SIMPLELINK-CC13X0-SDK

    2. I have not been able to reproduce this. On my side project B is still active after a failing debug session. 

    3. Both settings work for me. I have tried this with both a LAUNCHXL-CC2640R2 as XDS110 debugger and SimpleLink SensorTag Debugger DevPack as XDS110 debugger. What XDS110 debugger are you using?

    Best Regards,

    R.M

  • Hi RM

    My debugger is here.

    Could you please send me shot of the products you have installed .

    I have now this:

    But this gives me an error:


    **** Clean-only build of configuration Debug for project empty_min_CC1350STK_TI ****

    /media/p/nuage/dev/ti/ccs910/ccs/utils/bin/gmake -k -j 8 clean -O
     
    rm -rf  "empty_min_CC1350STK_TI.hex"  "configPkg/linker.cmd" "configPkg/compiler.opt"  "empty_min_CC1350STK_TI.out"
    rm -rf "CC1350STK.obj" "ccfg.obj" "empty_min.obj"
    rm -rf "CC1350STK.d" "ccfg.d" "empty_min.d"
    rm -rf  "configPkg/"
    Finished clean
     

    **** Build Finished ****

    **** Build of configuration Debug for project empty_min_CC1350STK_TI ****

    /media/p/nuage/dev/ti/ccs910/ccs/utils/bin/gmake -k -j 8 all -O
     
    Building file: "../empty_min.cfg"
    Invoking: XDCtools
    "/media/p/nuage/dev/ti/ccs910/xdctools_3_32_00_06_core/xs" --xdcpath="/media/p/nuage/dev/ti/simplelink_cc13x0_sdk_3_20_00_23/source;/media/p/nuage/dev/ti/simplelink_cc13x0_sdk_3_20_00_23/kernel/tirtos/packages;" xdc.tools.configuro -o configPkg -t ti.targets.arm.elf.M3 -p ti.platforms.simplelink:CC1350F128 -r release -c "/media/p/nuage/dev/ti/ccs910/ccs/tools/compiler/ti-cgt-arm_18.12.3.LTS" --compileOptions "-mv7M3 --code_state=16 --float_support=vfplib -me --include_path=\"/media/p/nuage/dev/ccs-ws/cbrix/empty_min_CC1350STK_TI\" --include_path=\"/media/p/nuage/dev/ccs-ws/cbrix/empty_min_CC1350STK_TI\" --include_path=\"/products/cc13xxware_2_04_03_17272\" --include_path=\"/media/p/nuage/dev/ti/ccs910/ccs/tools/compiler/ti-cgt-arm_18.12.3.LTS/include\" --define=ccs -g --diag_warning=225 --diag_warning=255 --diag_wrap=off --display_error_number --gen_func_subsections=on --abi=eabi  " "../empty_min.cfg"
    making package.mak (because of package.bld) ...
    generating interfaces for package configPkg (because package/package.xdc.inc is older than package.xdc) ...
    configuring empty_min.xem3 from package/cfg/empty_min_pem3.cfg ...
    subdir_rules.mk:17: recipe for target 'build-1807381457-inproc' failed
    js: "/media/p/nuage/dev/ccs-ws/cbrix/empty_min_CC1350STK_TI/empty_min.cfg", line 592: xdc.services.global.XDCException: xdc.PACKAGE_NOT_FOUND: can't locate the package 'ti.mw' along the path: '/media/p/nuage/dev/ti/simplelink_cc13x0_sdk_3_20_00_23/source;/media/p/nuage/dev/ti/simplelink_cc13x0_sdk_3_20_00_23/kernel/tirtos/packages;/media/p/nuage/dev/ti/ccs910/xdctools_3_32_00_06_core/packages;..;'. Ensure that the package path is set correctly.
        "./package/cfg/empty_min_pem3.cfg", line 180
    gmake: *** [package/cfg/empty_min_pem3.xdl] Error 1
    js: "/media/p/nuage/dev/ti/ccs910/xdctools_3_32_00_06_core/packages/xdc/tools/Cmdr.xs", line 51: Error: xdc.tools.configuro: configuration failed due to earlier errors (status = 2); 'linker.cmd' deleted.
    gmake[1]: *** [build-1807381457-inproc] Error 1
    gmake: *** No rule to make target 'build-1807381457', needed by 'configPkg/compiler.opt'.
    gmake: *** No rule to make target 'build-1807381457', needed by 'configPkg/linker.cmd'.
    gmake: *** No rule to make target 'build-1807381457', needed by 'configPkg/compiler.opt'.
    gmake: *** No rule to make target 'build-1807381457', needed by 'configPkg/compiler.opt'.
    gmake: *** No rule to make target 'build-1807381457', needed by 'configPkg/compiler.opt'.
    gmake: *** No rule to make target 'build-1807381457', needed by 'configPkg/compiler.opt'.
    gmake: Target 'all' not remade because of errors.

    **** Build Finished ****

    Thanks

    Peter

  • Hi Peter,

    Here's the settings for the tirtos_builds_CC1350STK_release_ccs (empty_CC1350STK_tirtos_ccs inherited this):

    Here's the setting for the empty_CC1350STK_tirtos_ccs:

    Looks like you are using a old XDCtools version?

    Best Regards,

    R.M

  • Hi R.M.

    In the pics you inserted, I can only see the Products Page, not the target conf neither the debug settings. Could you insert these as well ?

    Kind regards

    Peter

  • Hi R.M.

    I can confirm that the empty project and other sample projects for the CC1350STK (and the CC2650STK) now work fine.

    I am using the Sensor Tag DevPack rather than the XDS110 standalone debug probe and I can use the target configuration in the samples without further

    modifications. I removed the battery during debugging. I don't quite understand why the connection problems mentioned in this post disappeard after switching to the the DevPack debug probe, though.

    Anyway, many thanks !

    Kind regards

    Peter