This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADS8028EVM-PDK rev A on MMB0 rev D not installing driver in windows 8

Other Parts Discussed in Thread: ADS8028, ADCPRO


When trying to install MMB0 with ADS8028EVM in windows 8, the installer doesn't complain, but when I am looking in device manager I see that there is an unknown device on USB fabric, VID 0x0451, PID 0x9001, REV 0x0000.

When trying to install, I did the following sequence:

- install adcpro-launcher-1.0.1.exe

- from ADCPro launcher I installed ADCPro and the ADS8028 plugin

Note: I ran the installation of adcpro-launcher-1.0.1.exe as admin. For the others, since they were installed from ADCPro launcher, I don't know the credentials. But I am admin on the machine I used.

Started ADCPro, but after seeing that firmware couldn't be loaded, I checked the USB driver and saw the problem above mentioned.

After looking more closely in drivers locations:

1) C:\Program Files\ADCPro\drivers\driver\usbstyx.inf

2) C:\Program Files (x86)\ADCPro\pdk_lib\libmmb0\Styx\usbstyx_drivers\usbstyx.inf

I saw that the inf files are identical. By looking in amd64 directory (I have 64 bit system) and comparing binary files libusb0.sys I saw that they slightly differ.

Another observation I could make is that the drivers are not signed and this is making installation on windows vista, 7 and 8 difficult because we need to disable sign enforcement (used dseo13b.exe).

I tried to manually install the driver by disabling windows driver signature at startup and also dseo13b.exe, but I couldn't make it work.

Could you provide me with a driver that is confirmed to be working in windows 7 and a manual installation procedure that works? I am presently stuck with my project.

Thank you,

Tiberiu Teodorescu