TMS320F28379D: Device ID is not recognized

Part Number: TMS320F28379D
Other Parts Discussed in Thread: UNIFLASH, LAUNCHXL-F28379D

Tool/software:

Hello! I have a 28379d core board on hand, and what is the reason for the following error in the simulation?

Error connecting to the target:
(Error -1265 @ 0x0)
Device ID is not recognized or is not supported by driver. Confirm device and debug probe configuration is correct, or update device driver.
(Emulation package 12.7.0.00130)

The emulator uses a XDS100V2 and has tried the XDS200, and the situation is the same.

The original program on the board can also run, and can see the indicator light flashing.

The chip power supply check is normal, including 1.2V and 3.3V .

CCS version v12, I also tried to use UNIflash, but this error is also reported.

The same project burned to ti's official LAUNCHXL-F28379D board can be used normally.

  • Hi Pan,

    1) Looks like the failure is on your custom board - correct?

    2) If I understand correctly, you are able to load to this specific device's flash previously and are able to execute code fine from flash - Correct?

    3) If not this board, are you able to load to flash in devices on other boards?

    Thanks and regards,

    Vamsi

  • Hi Vamsi!

    Thank you for repply!

    1) Yes!

    2) The program for the custom board was loaded programe by my colleague a few months ago.

    3) I have 2 custom boards, an official TI LAUNCHXL-F28379D board, and the custom boards can correctly identify the chip through the xds200, but neither can burn a program.
    The same program can be burned to the LAUNCHXL-F28379D.

  • Hi Pan,

    Thank you for the information.

    2) Any changes made in the board or power supply after that?  

    Thanks and regards,

    Vamsi

  • Hi Pan,

    Did your colleague use the same CCS version and debug probe (and it's version) previously when it succeeded?

    Did you/your colleague operate the device on the board beyond the operating conditions specified in the datasheet?

    Thanks and Regards,

    Vamsi