This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

F28M36P63C2: FTDI Driver issues - XDS100v2

Part Number: F28M36P63C2
Other Parts Discussed in Thread: CONTROLSUITE, TMDSDOCK28M36


I am using CCS Version: and am trying to connect to the target via XDS100v2 debug probe. I am getting errors in regards to the FTDI driver.

I see that running the serialxds.exe gives me correct VID/PID:

VID/PID             Type                        Serial #               Description
0403/a6d0          XDS100v1/v2         XDS100v2         Texas Instruments Inc.XDS100 Ver 2.0

The device manager also shows XDS debug channels correctly installed:

The test connection works as well but it is still not able to connect to the target. I get the following error message:

IcePick_C_0: Error connecting to the target: (Error -151 @ 0x0) One of the FTDI driver functions used during the connect returned bad status or an error. The cause may be one or more of: no XDS100 is plugged in, invalid XDS100 serial number, blank XDS100 EEPROM, missing FTDI drivers, faulty USB cable. Use the xds100serial command-line utility in the 'common/uscif' folder to verify the XDS100 can be located. (Emulation package 6.0.579.0)

I have been at it for a couple of days. Can anyone please help me. I tried installing and updating the latest FTDI drivers as well. But no luck.