DRV8908-Q1EVM: Run java script from Open script window

Part Number: DRV8908-Q1EVM

I install Firefox and enabled the "javascript.options.shared_memory" setting that will now allow SharedArrayBuffer. Also set Firefox as default browser. Restarted the PC. But I still get the same message. Think it still uses Google Chrome or Edge, and I don't really want to uninstall them.

  • Hi Thomas,

    Can you specify what the error message is?

  • And I think you have to use Firefox but I don't wont to do that because our company policy is to use Edge or Chrome

  • Thomas,

    We are investigating.  Expect a response in 24 hours.

    Regards,

    Ryan

  • Hi Thomas,

    As Ryan stated, we are still investigating. Once I have a proper explanation i will post a reply.

    In the meantime, you can download the GUI and install it locally to your computer. Then you'll be able to run the GUI  without using the browser.

  • Hi Thomas,

    Were you able to get the GUI working after installing locally?

    Can you try the following steps:

    1. Using this link for the app, https://dev.ti.com/gallery/view/5063756/DRV89xx-Q1/ver/1.0.7/
      1. After the app connected to the device, select Tools -> Open Scripting Window from the main menu.
    1. In the opened scripting window
      1. You can run the default script by clicking on the green triangle toolbar button at the top. Let me know if you see the same error as before after doing this step. If same error, then uncomment line 27, 30, 31, 34, and 37 and press on the green triangle to run the script again. 
  • Hi Thomas,

    Any updates? are you able to run the GUI locally or through the browser?

  • From the beginning I was running it locally and then the original error came up, with the shared buffers when I wanted to run java scripts.

    And I thought that was a bit strange because I didn’t understand why it was using the browser.

     

    When I tried the browser one it doesn’t find the hardware just says “Hardware not connected”

    I notice when I put in the USB cable it says “Connecting to target” but right away it goes over to “Hardware not connected”.

    I have tried it on 3 different PC’s with the same symptoms.

  • Hi Thomas,

    IF the hardware is not connecting, it can mean that there is an issue with the USB connection. Can you try and go to options->serial port and choose a different USB serial port. Try all of the available ports.

    I'm also not sure why the local GUI requires the shared buffers. I will check this internally and get back to you by 24 hours

  • There is only one option COM3(FTDI)

    And the problem is still there "Hardware not connected"

  • Hi Thomas,

    Apologies for the long delay.

    Please follow these steps to get the hardware connected to the GUI:

    • Make sure the power supply is enabled and connected to the board
    • Connect the USB to the computer and the board
    • If in windows, go to "Device Manager" and check the "Ports (COM & LPT)" tab. Check that "MSP Application UART1" is listed when the USB is plugged in. If not, it means there is an issue with your computer reading the USB connection.
    • Go to the serial port tab in the GUI and select the COM corresponding to the MSP Application UART1 COM.

    Let me know if this works.

  • In Device manager it comes up as USB Serial Port(COM3) not as "MSP Application UART1) in the web interface and the local interface it comes up as I wrote before "COM3(FTDI)"  and since the integrated circuit for communication on the DRV8908-Q1EVM is of brand FTDI. I think the 3 different computers I tried it on detects the board via USB. If I disconnect the USB cable the it disappears.  Perhaps the DRV8908-Q1EVM board or the USB driver replies wrong name and has to be updated?

  • Thomas,

    Let me test it out in the lab with an EVM. Sometimes the GUI can experience issues connecting with the board. It doesn't happen all the time but it can occur in some cases. I will reply back to you within 24 hours.

  • Hi Thomas,

    There seems to be an issue with the GUI not connecting to the EVM. I tried it on my end and experience the same issue. We will look into this to understand what is causing the issue. Please give me two business days to research and I will get back to you with a reply by 6/28 or early.

  • Hi Thomas,

    Apologies for late reply.

    Can you confirm that the label on the EVM says MD020B. If it is, please follow these steps in order. I haven't had connection problems with these steps procedure:

    1. Provide power to EVM
    2. Connect EVM to PC via USB
    3. Start the GUI program

    The EVM will connect and the DRV8908 option will become available to select. Let me know if this does not fix the problem.

  • My labels says MD020E2 and I tried the steps you suggested it doesn't work. I have also tried to do the steps in different ways but it doesn't help.

  • Hi Thomas,

    How did you obtain this board. The E2 revision is the pre-production board and the firmware is an older version that the current EVM revision. The firmware on the E2 board is not compatible with the current GUI which explains the issues. I had the same connection issues as you do but after updating the firmware the EVM is able to connect to GUI.

    Please order a new EVM from the TI store. Many other hardware changes were made to the latest revision so you should be using the latest board.