This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV8825EVM: DRV8825EVM and CPG004-R1P1 Windows Tool

Part Number: DRV8825EVM
Other Parts Discussed in Thread: LAUNCHXL-F28379D

Can DRV8825EVM work with Windows 10?

I tried slvc342c and slvc502a packages. No luck. USB Communication on COM4 established with both packages - OK. Power supply 12V DC - OK. Stepper motor NEMA 17 12V/0.4A worked with Arduino before. Winding resistance ~30ohm - OK. Tried different positions of the jumpers - nothing works.

Thank you in advance.

  • Hi Dimitar,

    The DRV8825EVM can work with Windows 10. Please click the setup.exe file for Windows XP (Service Pack 3) prior to executing the file.

    If that does not not work, please report what you are observing.
    Does the GUI start? Based on your statements, it appears to.
    Are you sure COM4 is the EVM? This has been a problem in the past where the GUI connected to some other USB device.
  • Hi Rick,


    Thank you for your reply.


    I setup the compatibility for CPG004-5_DRV88xxEVM_R1p1.exe to Windows XP and for the setup.exe from the software package slvc502a to Windows XP.

    Both applications starting without problem. Both application connecting to the board  through COM4 (not at the same time because I am getting a message that the Port is busy). Both applications look like work fine. Status LED on the board is blinking. 3.3V LED is ON. VM LED is ON. No motor movement.

    I found this warning in the USB Serial Converter:



  • Hi Dimitar,

    Sorry for the delay. Can you try uninstalling and re-installing the USB device? Hopefully this will correct your communication issue.
  • Hi Rick,

    Thank you for your reply.

    I tried reinstalling the USB driver  several times. I did that and on a computer running Windows 7 PRO. No success.

  • Hi Dimitar,

    I am referring to the device, not just the driver.

    In the device manager, open the Ports (COM & LPT)
    Plug in the EVM and identify the COM port used.
    Right click the COM port and Select uninstall
    Check the Delete the driver software for this device
    Unplug the EVM
    Plug in the EVM to re-install
    If changed, note the new COM port
    Open the GUI and use the pulldown menu to select the correct COM port if necessary.

  • Hi Rick,

    Thank you for your advice.

    I fulfilled the steps as per your advice. The connection always establishes on COM4. I tried the connection on the other available ports manually (in my case COM1 and COM2). Everything looks fine. The GUI shows when the connection is done on COM4 or COM1, COM2. Clicking Connect and Disconnect it looks like it is working.

    I changed the stepper motor. The same thing. No movement.

    On the same USB ports I am using TI LaunchPad (LAUNCHXL-F28379D).



  • Hi Dimitar,

    Now that the COM port appears to be working, please try the following to confirm.

    Once the GUI is up and connected:

    Press the nSLEEP pin several times while monitoring the nSLEEP test point. Is the nSLEEP toggling high and low?
  • Hi Rick,

    Yes, it is toggling between 3.3V and 0V.

  • Hi Dimitar,

    Great. Now that communications is confirmed, let's get the motor running.

    Prior to connecting the motor, please set and confirm the following:

    nRESET is high
    nSLEEP is high
    MODE2/1/0 is low/high/high respectively (8 microsteps/step)
    DECAY is high
    DIR is low
    VREF = 1V
    nENBL is low

    At this point the outputs should be active with AOUT1 and BOUT1 at ~VM and AOUT2 and BOUT2 at GND.

    Once this is confirmed, disable the outputs by setting nSLEEP low.
    Connect the motor
    Set VREF to the current required
    Set nSLEEP high. The motor should have current flowing through it
    Click "Start Steps" and the motor should start turning.

    If the motor is not turning, please check the nFAULT pin.
  • Hi Rick,

    Thank you very much for your help.
    Everything is OK now.