This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ27742-G1: BQ27742-G1

Part Number: BQ27742-G1


I'm currently working on bq27742. Till now there is no issue while unseal of the IC. But when I tried to check a scenario, like while updating data flash parameters, knowingly I removed battery. So the flash is not updated properly. Then, I tried to unseal the IC using BQ Studio. But, the Full Access Unseal command is not happening to work. When I saw the FAS,SS bit are HIGH only. Not going to LOW state. Can you suggest any solution, how I can go into unseal state.

Thanks & Regards,


  • Unsealing (and Full Access) requires two consecutive words written to the gauge. The auto-refresh may interfere with this. Please disable auto refresh (click on the green line in the Dashboard, top left. It'll turn red when auto refresh is disabled).

    Wait 4 seconds to let the two word command state machine time out.

    Then click on Unseal (this is the first step). Check that SS is 0 (click on Refresh to update this manually).

    Then click on Unseal Full Access. Check that FAS is 0 (click on Refresh to update this manually).

  • Hi Dominik,

    I tried your suggestion, but unable to get out of sealed state. Can you suggest other way.

    Thanks & Regards,


  • Hello Kavya,

    If you removed power while programming the srec, then it can cause data corruption. The bq27742 would be unpredictable when the data is incorrect ( wrong instruction flash). I would treat this unit as bricked.

    Note that if you try this on another unit, it may work fine because there are safeguards to prevent this from happening but there is only so much that can be done.

    I would recommend that you try to reprogram the srec a few times. If that succeeds, then you would have recovered the bq27742.