This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ76952EVM: I2C Comms Issue with EV2400

Part Number: BQ76952EVM
Other Parts Discussed in Thread: BQ76952, EV2400, BQSTUDIO

My bq76952 evm is unable to communicate with ev2400 over i2c. The evm communicates fine over i2c with the usb cable (via onboard uctrl thats on the evm). 

Is there any jumper setting i need to do to allow external i2c comms (ev2400 is external)? I already tried removing j16 and j19, but that didnt make any difference

Note that I know ev2400 has no issue since i use it to communicate with ti guage evm

  • Hi Fahad,

    You did the right thing by following the evm user guide and removing j16 and j19; however, there may be a few additional steps you need to complete.  To communicate with the evm using an external ev2400, please try these two things:

    1) Ensure that the only connection to the evm is through the external ev2400.  If both the onboard and external ev2400s are connected simultaneously, BQStudio may still be communicating with the onboard EV2400.  To disconnect the evm's onboard ev2400, just unplug the USB cable running directly from the computer to the evm.

    2) Make sure to update the ev2400's firmware to the latest version (version 0.32).  Firmware updates can be found at this link: EV2400 Interface adapter |



  • Thanks for the reply.

    I updated the EV2400 firmware from 0.18 to 0.32 but no difference

    I also thought pull ups on external ev2400 maybe weak (20kohm) so I connected pull up resistors ( by turning on Reg0 and Reg 12 (for 3.3V) and connecting j15 and j18), it doesnt really make much difference. Although sometimes when I start bqstudio, it recognizes the devices automatically but then looses i2c comms 2 or 3 seconds later and then it doesnt come back 

  • Hi Fahad,

    Just to double check, did you complete step one, making sure only one ev2400 is connected?



  • Yes, usb cable is always disconnected 

  • Hi Fahad,

    Can you show a picture of your setup? Are you connecting to the I2C port of the EV2400?



  • Ok so it seems to be working now, but connection keeps cutting in and out. It feels like one needs to program a certain comms mode in the bq76952 evm to make it work with external ev2400 in stable manner (100khz, 100khz with crc, 400khz, 400khz with crc). I have not tried these combinations, my evm is currently set to default (not sure which one of these four is default)

  • The default settings should work fine. I recommend that J16 and J19 should be removed (I think you have already done this), J15 and J18 should also be removed (the EV2400 has I2C pullup resistors internally pulling to 3.3V). Make sure you are using a recent version of BQStudio (I think you are since it recognizes this device). 

    If you capture an image of the BQStudio screen, I can take a quick look to see if I spot any potential issues.