This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ27742-G1: BQ27742-G1 Fails to Establish Communication with EV2400 via I2C Interface

Part Number: BQ27742-G1
Other Parts Discussed in Thread: EV2400, BQSTUDIO, BQ27742EVM

Hello everyone,

I'm currently in the process of working with the EV2400 tool to execute the learning cycle of the BQ27742-G1 module.

Unfortunately, the bqStudio software isn't detecting the BQ27742-G1 module at all. Additionally, I've encountered the following message:

"The detected device is not compatible with this application! Certain actions could potentially lead the device to lose communication permanently and become unrecoverable. Please proceed with caution. Click 'OK' to continue or 'Cancel' to close the application."

Upon clicking "OK," the software briefly displays the device, but it remains disconnected afterward.

In addition, I'd like to note that I don't possess a BQ27742EVM kit. Instead, I'm attempting to establish a connection between the EV2400 and a custom board containing the BQ27742-G1 module through the I2C interface.

While I try communicating with the BQ27742-G1 using an MCU, it can communicate normally, and I was successfully retrieving the FW Version code.

I would really appreciate the help!

EV2400 Firmware: Version 0.18 (the same with version 0.32)

bqStudio version 1.3.101.

*Here is what is look like on the app's side.

  • Hello Thanh,

    How do the waveforms look on the communication lines?

  • Hi Shirish,

    This is how it appears when I attempt to communicate with the BQ27742-G1 via an MCU:

    I tried to read the Firmware version, and the waveform seems to be correct.

    And this is how it appears when I connect the module to the EV2400.

    The SDA line remains pulled up consistently. I tried running the analyzer throughout the entire setup process, but the result remains the same.

  • Check the physical connection of the SDA line. If everything looks ok, then disconnect the bq27742 and check the waveform at EV2400. If you do not see SDA going low, but clock is toggling, then there may be an issue with the EV2400 box

  • Hi,

    Thanks for the help!

    After double check the SDA line, I figured out that the MCU never release the I2C bus, because I'm working with the PCB that connect the MCU and the BQ27742-G1 all the time, even after I erased the firmware, which I guess would cause the GPIO that control the SDA fall into it default state (which its pull-up in my case).

    As a solution, I reinitialized the I2C on the MCU, allowing both the Master (MCU and the EV2400) to alternately drive the BQ27742-G1 and it actually worked!