This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

EV2300 64-bit drivers available for download

Genius 14985 points
Other Parts Discussed in Thread: EV2400, BQ2084-V143, BQ78350, BQ76930

The "unofficial" 64-bit Windows drivers are now available for download from the Files section of the Battery Management forum.

Here is the direct link:

EV2300 64-bit Windows drivers

Why are they unofficial?

First, the officially supported tool to use with 64-bit Windows is the EV2400 which is now available for ordering.

Second, the 64-bit EV2300 USB implementation may conflict with other products that use the same default PID on the USB bus, like the TUSB3210 EVM.

Third, it hasn't been extensively tested on all Windows software and hardware configurations.

  • HI,

    I have installed this drivers on my Win7 64bit and the EV2300 is still not recognized... 

    Must I do something more ?

    (It's the first drivers for your EVM I install. I haven't installed the TUSB3210 EVM)

    On your EVM section for the bq2084-V143 you ay to buy the EV2300 so I buy it ... Why don't say to buy the EV2400 so... :(

  • when installing any of these gauge and EV2300 drivers on WIN7 you should make sure to right click and install as administrator otherwise key file don't get written properly. Did you do that.If not try reinstalling that way

  • I have same problem. I just got an EV2300 to use with TPS2384EVM and also can't get the driver to work in Win7 X64

    Yeah no mention of EV2400 there either. Ti you need to clean up your website!!!!

    So is there any way to get this working or do I need to order a EVM2400 (and then will the TPS2384EVM software work with that?)

  • Thanks for the feedback everyone.  We are trying to find a way to easily cross-reference compatibility between combinations of OS versions, USB-I2C adapters (EV2300 and EV2400), and our SW tools and hopefully we can make all of this clearer somehow.

    Bart, if you install the 64-bit drivers for EV2300, for some older software you will also need to install

    the support components that enable the software to see use EV2400 and EV2300.

    It is available for download from the EV2400 wiki page

    Specific link


  • Very bad indeed.

    I just bought this week the bq2804evm and it was said in the order page that I needed EV2300.

    Now, I'm stuck and can't install the EV2300 drivers either.

    It's brand new. Just got it yesterday and it is already obsolete.

    I wish there was some more info that we should not purchase this and go with the EV2400 instead.

    I tried the new 64 bit drivers and also tried running as administrator and when I plug the module, it still says unknown device and it fails to properly install drivers.

    What should I do?

  • Hi,

    I have an identical problem. Most of my colleagues have not it. They use some MS Windows 7 SP1 x64 as I. But one colleague has the problem also. I compared our work station. We have an identical HW (unlike people who have no problem).
    I think HW configuration is reason of issue.

  • I have installed on Windows 8. Nothing is happened. There is no reaction at all.
  • Hi,I would like to ask what time to burn the bq78350(我该什么时候给bq78350烧写Firmware,因为我想做一块电源管理电路bq78350+bq76930)

  • I am not sure about the question that you are asking. The Chinese translator says that you are asking when should you program the bq78350 firmware. What does this mean?
  • I tried this on the Windows 7 64bit...
    It doesnt work.

    This issue was old but still not fixed???
    Been browsing for quite some time now and trying to install drivers from this site for EV2300 Windows7 64 Bit. Cannot make it work.

    Can somebody help us on this...
  • Hello Sime

    Sime Darby said:

    Can somebody help us on this...

    No, there won't be any help. TI obviously does not plan to fix this issue as the EV2400 needs to be sold...

    We tried several Win7 x64 systems here until we finally found one where the unofficial drivers from this thread mysteriously worked. We even tried installing Virtual Machines with x86 Windows, but that did not work either.

    Good luck. <- this is all that might help you ;-)


  • Hi Daniel,

    Please don't think there is a marketing conspiracy to sell EV2400.  :)   EV2300 was originally an internal engineering tool created long before 64-bit Windows was on anyone's radar.  It ended up getting released to assist customers using our gauges but has a technical gap in being something that we can stand behind as working on all 64-bit systems.  We've made our best effort to continue supporting EV2300 with the unofficial 64-bit Windows drivers linked in the first post above.  Those drivers tend to work in 99% of the cases, but on some systems they mysteriously don't.  In one of my cases the driver worked fine for a year then suddenly stopped working and even the driver's author couldn't figure out what was going on.

    We realize that many customers are frustrated with trying to get EV2300 to work on their system, which is why we try to point them to EV2400 as their first choice.  It requires no driver installation and should work right out of the box since Windows recognizes it as an HID device just like a keyboard or mouse.

  • I'm pretty disappointed with TI right now.
    Firstly there is no warning that the EV2300 is no longer supported or not supported by current windows versions. The EV2300 was listed as a valid device for the bq chip evaluation kit that i ordered.
    Secondly to charge $200 for a simple interface is frankly exploitation, more so in that it is for evaluation, something that TI should encourage for designers to adopt it's devices.
    I now have a current evaluation kit, purchased through official channels that i cannot get to work.
  • What is the last line?
    I have Windows 8 and going to upgrade to Windows 10.
    So should I buy EV2300 or EV2400?
  • We´ve tried to install "unofficial 64 bit EV2300 driver" to few PC running W10, all without success. My colleague spent a lot of time to solve this problem. He recognized the problem is missing GUID in aploader.inf file. Modified part should be like this:


    The problem is there is necessary to digitally sign the driver after modification of the file. TI should do this. We signed it for our own use, because we certify our drivers normally, but we cannot publish this version.