This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS560200: Not providing stable output.

Part Number: TPS560200

I am bringing up a new design with 2 instances of this device and neither of them are behaving as expected. I know I have R1 & R2 switched so I have corrected for that but still no luck.

I have the enables floating, so I tried pulling them up to the 6V input which did give me some output voltage and current but again the voltage is around 2.8V for what should be a 3.3V output. The voltage fluctuates but I haven't had an opportunity to put it on a scope but my feeling is that it is oscillating wildly.

I replaced both devices in case they were damaged, but I get the same results. In fact now the 3.3V is outputting over 5V so I suspect a blown device.

I have used low ESR ceramic caps and followed the layout guidelines. The only difference I can see is that I have used a different inductor; still 10uH but a larger series resistance of 390mOhm. 

Any help appreciated.