This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS2511: Charge Current to Samsung Tablet Limited to 100mA

Part Number: TPS2511


I have a TPS2511 circuit that is intended to charge newer Samsung Tab A Tablet (T510 Series) but the charge current never goes about 100mA.  Is there something that is wrong with the circuit or is the Tab A so new that it doesn't recognize any of the legacy handshaking protocols?

I'll attach a screenshot of the schematic and a waveform showing the D+ and D- signals when the cable is plugged in.  The current limit resistor is set to 44.2K so it should be able to supply 1.2A.

  • NOTE:  I also tried swapping D+/D- for the 10W configuration and I get the same 100mA charge current.

    Also, the battery is only around 35% so I would expect that I should get more than 100mA in charge current.

  • Hello,

    I've assigned this issue to the relevant expert who will get back to you shortly

  • Hi James,

    Your current limit is set at 1.1A so the charge current will be limited by the current limit resistor in the 10W application. Can you try changing out that resistor, R1, to 16.9k? Also, can you try a different charging device to see if you see the same result?



  • Hi Emma,

    I will try that.  But why would I be seeing 100mA of current instead of 1.1A?


  • OK, so I think I figured out what is going on here.  The USB voltage was dropping too much.  The USB adapter voltage I was using was a bit low to start with and I had an extra length of USB cable with a cut in the VUSB line to put through a current meter.  I changed the setup to not need that and powered with a lab supply where I could set the voltage and read the current directly.

    Now I'm seeing an additional 1A due to tablet charging.  The voltage at the connector to the tablet is 4.98V.  If I boost up the power supply so that voltage at the connector is 5.25V then the charge current is still 1A.

    I have it wired with R1 = 16.5K (closest I had in stock) and wired for 10W.  I would expect to see more current.



  • With the above setup, I unplugged the tablet and plugged it back in and now it is taking 1.3A.  I guess it needed to go through the protocol again to take advantage of the higher voltage of 5.25V.

    But with 16.5K I would expect it should take up to 3A?  I guess it doesn't matter in our case as our limit is 1.2A, but I'd like to understand why we don't get 3A.

  • OK, another step. I bumped up the current limit on the power supply and got a bit more current of 1.4A or so.  1.4A @ 5.25V = 7.35W.  Still not 10W.

    Reseting my circuit to 5W behaviour since that is what fits in our power budget.

  • So I wired up with 5W configuration and set R(LIM) to 52.3K and now I have a ~0.99A charge current.  So it is behaving as I expect.  Not quite sure how to explain some of the behaviour above.

  • Hi James,

    I'm glad you were able to solve some of your issues. One thing I'll mention that it looks like you are in DCP from your scope capture. While you have the hardware setup to use Divider 2 (10W) as an option, it appears that the tablet you are connecting is negotiating DCP. In which case, the DCP current limit is 1.5A, as shown below:

    If this is the case, then this particular tablet will max at 1.5A. Check to see if the tablet can support Divider 2 get back to me and we will debug from there. 



  • Hi Emma,

    That explains it.  Yes, I have a DCP configuration.  I only want about 1A and I have that now.  I was just wondering why I wasn't getting 3A when RLIM was set accordingly.  So that explains it.

    I always prefer understanding why the chip behaves the way it does, even though I'm not using that mode.  It gives me more confidence that it will behave the way I think it should :)