This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.


Part Number: MSP432P401R

Tool/software: Code Composer Studio


I tried to load the demo project "blelock_MSP_EXP432P401R_tirtos_ccs" , but I get the following error, I will appreciate if you help me figure it out.

I use CCS

CORTEX_M4_0: GEL: Encountered a problem loading file: C:\Users\mn\Workspace\blelock_MSP_EXP432P401R_tirtos_ccs\Debug\blelock_MSP_EXP432P401R_tirtos_ccs.out Could not open file

  • Is the file there? There are a couple ways to check. In CCS you can go to the project, expand the Debug folder and look for blelock_MSP_EXP432P401R_tirtos_ccs.out or you can go to Windows explorer and browse to the path specified in the message and check.

    If the file is not there then it seems like the project is not built. You can click on the project in CCS and then click on the build button in (looks like a hammer). You should then be able to click on the bug button to launch a debug session and load the program.

    Where did the example come from?

  • Dear John,

    Thank you for your reply. The file is not there and I tried to build the project but I received the following error:

    **** Build Finished ****
    Buildfile generation error occurred..
    Cannot build project. Referenced RTSC Configuration project 'tirtos_builds_MSP_EXP432P401R_tidm1004_ccs' contains build-errors.
    Build stopped..

    I download the example  TIDM-432CAPELOCK Software   from this link:

  • When you build the example project it will first build the RTOS project.  

    In this case it is failing to build.  If you click on that project in the project explorer the problems view should give some more information on what is going wrong.  It could be as simple as some required products not being installed.  When I read the app note I see that both the SimpleLink SDK for MSP432P4 and the SimpleLink SDK BLE plugin are required.  These can be installed from Resource Explorer.

    I also found that the RTOS project was set to use an older version of XDCTools (3.32).  I had to change this to use a newer version.

    You can change that in the project properties here:

    After doing that I right clicked on the rtos project and selected clean.  And then I click on build and it built ok.  I was then able to build the example project fine.  I suspect that this app note was written using an older version of the SDK.



  • Dear John,

    Thanks again, I have already done all these steps. But  "tirtos_builds_MSP_EXP432P401R_tidm1004_ccs" project built without error. But when I try to build the  "blelock_MSP_EXP432P401R_tirtos_ccs" , I get errors. I have copied the problem view here.

    and this is the installed SDK.


  • I am going to download the 2.10 version of the SDK and try that. My version is 1.60. I will let you know what my results are.
  • If I switch to the 2.10 version of the SDK I get the same grlib error. Try switching your rtos project to use 1.60. Then clean the rtos project, build the rtos project. Then build the example.

  • Thank you John, it solved my problem.