This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/EK-TM4C129EXL: Importing Energia Sketch (Cannot use EEPROM library)

Part Number: EK-TM4C129EXL
Other Parts Discussed in Thread: ENERGIA

Tool/software: Code Composer Studio

I have an Energia sketch which used Energia's EEPROM library. Sketch works perfectly on Energia IDE but because of i need to debug my project, i want to use Code Composer Studio. 

If i include this sketch to Code Composer Studio i can't use EEPROM library. If i remove everything about EEPROM i can build & debug my sketch on Code Composer Studio.

This is the error i get :

C:/Users/MyUserName/Documents/Energia/libraries/EEPROM/EEPROM.h:25:24: fatal error: avr/eeprom.h: No such file or directory
 #include <avr/eeprom.h>

  • In general, this error means that the compiler could not find the file avr/eeprom.h because it does not know the path to it. You could try adding the path to the compiler's include path option in the CCS project properties. 

    I haven't worked with Energia's EEPROM library to comment on whether there are other details to take into consideration but I would start with adding the path to the header file and see if that gets you going. If you still have trouble after that, it might be a good idea to also ask the question at the Energia forums as other Energia users might have already tried something similar and may able to provide additional advice.