TMS320C6713B:sine8_LEDS problem

Part Number: TMS320C6713B

Hello. 

I've seen a lot of posts about getting started with 6713, but can't find the solution about this problem, which I've showed below. 

Here is my code : 

Here is my tree : 

and here is the result : 

I would like to ask you about help with this. It isn't a "-dCHIP_6713" or something like that because I've done it. 

It is an example from one of most popular books to learn how to program 6713. 

Everything like for example an emulator or libraries has been checked by me. 

  • Hello,

    It isn't a "-dCHIP_6713" or something like that because I've done it. 

    The issue is that it appears you added "-dCHIP_6713" as the preprocessor symbol. This is incorrect. It should be "CHIP_6713". The "-d" is the compiler option, the same as "--define=" and hence you don't need to add that yourself.

    Thanks

    ki

  • I have fixed it, but unfortunately I have an another problem. 

    78 errors have been detected in compilation of c6713dskinit.c

    here is what has happened : 

     1st part of header problem

     2nd part of header problem

    and that is the compilation result : 

    I tried even include the library "c6713dskinit.h" in my main function but it dose not work and the result is the same. 

  • Looks like your copy of the header file has a whitespace character after the "\" on each line. Removing it from each line should resolve the error.