This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Buggy LME49600 spice model does not work, BUF634A is fine in same circuit

Other Parts Discussed in Thread: LME49600, BUF634A, TINA-TI, BUF634

Dear all,

[EDIT: This seems to be a bug in the LME49600 model as shown in my reply below. Can anyone fix its model ?]

I like the LME49600 for its low distortion and simple use as a high current driver in various applications and easy thermal management due to DPAK package.

I want to use it in a new role now, where I havent used it before: as a common buffer to tie the midpoint of a 36V supply to ground regardless of load imbalances.

Please refer to the figure below. I have used the spice LIB from the TI page of the LME49600 and BUF634A respectively. On the left is a usual output buffer circuit that I have used already and which simulates with no problems. The circuit on the right is a minimal model of the common buffer. It cannot simulate or (if forced) it diverges to one rail or starts at a huge input/output difference of 250 Megavolt (which should be clamped by internal diodes). If I plug the BUF634A model into the same circuit, it simulates without issue keeping the COM at close to GND.

So are the BUF634A and LME49600 indeed  functionally different ?? I always thought of them as roughly the same in a different package.

If they are indeed similar: Can you please point out how to "fix" the spice model of the LME49600 ?

I feel the BUF would be a little too shaky for the expected current loads due to bad heat dissipation.

  • I still could not solve the problem but I am now convinced that something is definitely fishy with the LME49600 model. I did some more tests and it looks like the LME has an integrated current source or something that produces strange voltages.

    Look at the attached figure. I forced the simulation with some resistors around the LME. The LME derails to the negative end of the PSU. If you inspect the voltages on its pins, you realize that the VEE node produces voltages in excess of anything in the whole circuit! The VCC-VEE voltage is much greater than the 36 V on the actual supply rails... Im not so good at spice that I could spot the bug in the LIB file myself. But maybe there is someone capable here ?


  • Hi, Tobias,

    Unfortunately, I haven't found a solution for this. I'm still working on it. However, in the meantime, would it work for you if you try with the LME49600 TINA-TI Reference Design?

    This is a high current audio buffer macromodel test circuit. It could be used for your analysis purposes.

    Best regards,
    Luis Fernando Rodríguez S.

  • Dear Luis,

    thanks for responding. I am not sure if you are suggesting that I try the Tina Spice model instead of the Pspice model (Just tried, same faulty behaviour in both LIBs) or if you are suggesting that I try your circuit . As for the latter: this is the usual buffer application that I have posted already in my initial post on the left side of the schematic. This circuit simulates flawlessly. The problem appears only in the COM buffer application. But as the COM Buffer simulates nicely with the BUF634, and I see some anomalous behavior with the LME model, I suspect that the LME model has some issue.

    I also tried terminating the BW pin with a resistor to VEE, as suggested in the comments of the LIB file. But it didnt change anything.

    Another test: Putting only the LME and connecting no power supply but only a resistor between VCC and VEE puts a constant current of ~5mA through the resistor, and yields 1 megavolt at the input pin..

    EDIT: sorry, just noticed the big attachment in your post :) I don't know how to integrate TSC files into LTspice, is it possible ?

    Regards, Tobias

  • Hi, Tobias,

    Sorry for the confusion. I suggested the attached file in order to test and measure the values in TINA-Ti. Have you used this software to simulate the circuit and do an analysis with the measurement tools?

    Best regards,
    Luis Fernando Rodríguez S.

  • I didn't test any of this in TINA, I am only using LTspice and used LTspice for all tests reported above. I don't think the spice tool makes a difference though ? All other OPAMP models from TI have integrated seamlessly with LTspice.

  • Hi, Tobias,

    Could you try with the TINA model that I attached in previous E2E posts?

    This is just to verify if the problem is related to the model or not.

    Best regards,
    Luis Fernando Rodríguez S.

  • Hi,

    Installation of TINA failed due to what appears to be a problem with rights on the PC. Unfortunately I cannot bugfix this quickly. If anyone could try to two circuits from my opening post in TINA, that would be welcome.

    Thanks a lot, Tobias