This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

EV2400: bq27x10EVM

Part Number: EV2400
Other Parts Discussed in Thread: BQEVSW

I am having issues with programming the EEPROM on the bq27x10EVM when interfaced with the EV2400 board. the data is not getting persisted when I write to EEPROM. I am connected out of the PORT3 HDQ to the bq27x10EVM board the Communication Status shows OK.
so when connected from Port3 (HDQ) of EV2400 to the bq27X10 board the communication status is OK.
when I try to go to the EEPROM tab and change the value of Initial LMD from 44 to 63 it does not persist after I write the values to EEPROM. see attached image

Also on one of my windows 10 computer, I am getting the following error,it is not allowing me to uninstall it - bq27x10 single-cell battery gas gauge. see an attached error message.

after the application starts, I   get the error message and when I close the error message by pressing ok the application closes too. also, i tried to uninstall the program it does not allow me to do so. it gives the following error message

  • Hi Team,

    Just like to update regarding this query.

    Thanks and regards,


  • Aditya,

    I have assigned this case to someone from our tools team to take a look since this appears to be a tools issue.

    Have you tried installing and running the bqEVSW programs in admin mode? 


    Eric Vos

  • Hello Aditya,

    Here are some suggestions and comments

    bq27X10 EVSW was built on Windows XP or older operating systems. Running it on Windows 10 may not always be successful. Make sure to install and run it as administrator for a higher chance of success.

    The bq27X10 software was designed to work with the EV2300. There was an attempt to keep the EV2400 backward compatible. This led to considerable success making many of the old software releases work with EV2400. However backward compatibility is not 100% guaranteed. I suggest trying with an EV2300.

    Port not available/connected messages imply that the EV2400 was not recognized. The word "port" suggests that this software may have been originally designed for EV2200 and then upgraded to use EV2300.

    The uninstall issues may be because the program uses 16 bit dependencies/components that are not available on newer Windows. You can delete the installation folder manually and then try to "uninstall". Windows is likely to remove it from the installed programs list when it does not find the associated files. I haven't tried this but it may be worth a try. You will need administrator access to try it.