This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Smart RF Studio 7 Installation Problem

Other Parts Discussed in Thread: MSP432P401R, CC110L, MSP430G2553, MSP430FR5969

Hey everyone,

I've spent a bunch of time today trying to get SmartRF studioworking and I'm stumped. I run the installer, and it completes successfully, but it never puts anything in the start menu. I'm fine with that if it still works, but when I go fish out the executable from the program files directory it doesn't work properly.

I'm trying to connect SmartRF studio to a CC2538EM attached to a SmartRF06 board. When I launch it from program files (using the startup_window.exe file) the device never shows up. And when I hit refresh/find device I get the error message "startup_window.exe has stopped working" and I get no more information past that. Does anyone have an idea on how I can get this program working properly?

For the record I am running Windows 7 64 bit, SP1. Let me know if there's any other information I should provide.

  • I have exactly same problem with both "SmartRf Studio" and "Flash Programmer 2" on my 64 Bit Win 7 SP1 machine.
    Both programs are installed and executed under system administrator account.

    Below are system event log snippets

    Smart RF Studio:

    Description:
    Faulting application name: startup_window.exe, version: 1.0.3.0, time stamp: 0x51d690b7
    Faulting module name: fastprox.dll, version: 6.1.7601.17514, time stamp: 0x4ce7b809
    Exception code: 0xc0000005
    Fault offset: 0x0005858c
    Faulting process id: 0x1fa0
    Faulting application start time: 0x01ced626bbf458f2

    Faulting application path: C:\Program Files (x86)\Texas Instruments\SmartRF Tools\SmartRF Studio 7\bin\startup_window.exe
    Faulting module path: C:\Windows\system32\wbem\fastprox.dll
    ________________________________________________________

    Flash Programmer 2:

    Description:
    Faulting application name: gui_flash_programmer.exe, version: 1.2.0.0, time stamp: 0x521f5574
    Faulting module name: fastprox.dll, version: 6.1.7601.17514, time stamp: 0x4ce7b809
    Exception code: 0xc0000005
    Fault offset: 0x0005858c
    Faulting process id: 0x1cdc
    Faulting application start time: 0x01ced624e2358222
    Faulting application path: C:\Program Files (x86)\Texas Instruments\SmartRF Tools\Flash Programmer 2\bin\gui_flash_programmer.exe
    Faulting module path: C:\Windows\system32\wbem\fastprox.dll

  • Hi,

    I don't know if these problems are related, but in the log snippets from Georgi the module fastprox.dll is mentioned. The following links give some information about errors related to fastprox.dll:
    http://www.retinapost.com/fastprox-dll-error.php
    http://windows-dll.com/en-us/what/fastprox-dll/
    The only thing that is a bit odd is if SmartRF Studio or SmartRF Flash programmer is the only programs that give this problem.

    If you installed SmartRF Studio under the default directory: "Program Files", it would be interesting to see if it makes any differences to install under another location. E.g. "C:\Texas Instruments".

    Starting the application from "startup_window.exe" should normally work fine so there is definetily something wrong with the installation.

    I'm working on a machine with Win 7 64 bit, SP1 myself and have never experienced this problem. Since there is nothing created on the Startup menu it could be interesting to see if there is any messages during installation about this. When the installation is finished there is a log window with all actions. Nearly at the top of the log there should be some lines with "Create shortcut". Below is a screenshot from my PC:

    I'm afraid I don't have an easy answer on this problem for the moment, but I hope this can give some hints.

    Regards,
    Øyvind

  • Hey I know you probably blacked out the user name for a reason, but was it an administrator account by any chance? I found out where the shortcut went on my machine by looking at that spot you showed in the log file, and it put it in the Admin directory on a computer where I am not an administrator. So could not being an administrator be the problem?

    I do know administrator credentials for this computer though if that will help for the installation. 

    Edit: I tried logging in as an administrator and installing (not just running the installer  as adminstrator). It still did not run on either the original account or the adminstrator account. 

    I also tried installing to the C:\Texas Instruments directory (which I labelled C:\ti on my PC). This did not help either. 

    Edit 2: It ended up not crashing when I kept the old instance of the program open after it crashed (leaving it in it's error message state), and then opening up a new window and trying again. At this point however it would fail to find the device.

    Also, I noticed that the Smart RF06 board will not show up as a "Cebal controlled device" like the guide said it would. Hopefully that little extra bit of information can lead somewhere. 

    Edit 3: I also looked at the system events log like Georgi, and this is what came out:

    Faulting application name: startup_window.exe, version: 1.14.2.1, time stamp: 0x52a1db79
    Faulting module name: dal_access.dll, version: 0.0.0.0, time stamp: 0x52a1d8ac
    Exception code: 0xc0000409
    Fault offset: 0x00067839
    Faulting process id: 0x101c
    Faulting application start time: 0x01cef835fe3cf591
    Faulting application path: C:\Program Files (x86)\Texas Instruments\SmartRF Studio 7\bin\startup_window.exe
    Faulting module path: C:\Program Files (x86)\Texas Instruments\SmartRF Studio 7\bin\dal_access.dll
    Report Id: 404f44a6-6429-11e3-9a34-005056c00008

    Any idea what this means?

  • Hi Ben,

    Administrator rights is needed to install SmartRF Studio. Normally this is indicated with a small "shield" on the icon of the installer. I thought installing without Admin rights would be reported with a clear message. On the other hand I have never tried this since I always have had admin rights. We need to test this and make some improvements.

    Just to be sure I understand this right: Installing with admin rights is successfully but starting a session from the startup window fails?

    Are you able to repeat the scenario described in "Edit2"?

    The SmartRF06EB board will not show up as "Cebal controlled device" because it uses a different interface. I was not able to find where it is described as "Cebal device", but if you could tell me which user guide this is mentioned, I could take action to get this updated. The interface is based on an XDS100 emulator and the device will be visible in the device manager as shown in the screen shot below:

    In SmartRF Studio you have to click on the "Refresh" button to get this device in the list of connected devices. The list will not be updated automatically when you connect the device. When the list has been updated it will look like shown below:

    The target device will be listed as "unknown". When you double click on the list item you will get a popup dialog asking for the type of target device. If you don't see anything in the list of connected devices after a refresh of the list I suspect that something is wrong with the driver installation. Verify that the Device Manager looks like the screenshot above.

    Regards,
    Øyvind

     

  • Sorry for the late response,

    I ended up getting smartRF studio running on an XP machine, so I didn't need that detailed response right away. I'm responding now in case others run into this issue. The issue has shown up in other Win7 machines in the office, so it seems likely.

    I am able to recreate the scenario described in Edit 2. Doing a refresh will not crash the second window if the old window is left open after the crash. However the device will not show up in the second window. Also, I clicked "Run as Administrator" when installing and running it every time. 

    Moving on, the device manager does look like the picture you described under the USB header. 

    So the problem still remains. The device will not show up on the window starting, and clicking refresh will either not work if under the condition in Edit 2, or the program will crash. 

  • Hi Ben,

    Thanks for the feedback. I'm glad to hear to you where able to move on with an XP machine. However, the problem still remains and we have to search further. For the moment we are working on a new release for SmartRF Studio (1.15.0). This will include some updates for the "XDS" interface. Some improvements have been implemented to make it more robust. Problem is that we are not able to verify if this issue is solved or not. If you have the possibility and time to do a test with the new version that would be great. I will let you know when it is available.

    Anyhow, thanks again for your patience.

    Regards,
    Øyvind

  • Hi Ben,

    A new version of SmartRF Studio (1.15.0) have been posted for the WEB. It will take a day or two before it is availabel for download but over here we are heading for the Christmas holidays so I wanted to let you know.

    Regards,
    Øyvind

  • I have tried 1.15.0 version too.
    Problem still persists. Application is crashing on “refresh” with all the same symptoms.

    Yet another suspicion:
    My PC is on domain network? Could it be related by any chance?

     

  • Hi Georgi,

    A PC on a domain network should normally not be a problem. The only thing I can think of is if there is some policy that put restrictions on the USB port. I don't know much about this, but I think it is possible for example to deny the use of memory sticks.

    To make sure you get the correct drivers installed it would be worth a try to uninstall the drivers for "XDS100" devices. Select "Show hidden devices" under "View" in the device manager to ensure that you see them all. Then uninstall and install SmartRF Studio again.

    Regards,
    Øyvind

  • Almost three years later this problem still exists?
    I just installed SmartRF Studio 2.4.2 on my Windoze 8.1 machine. Even though I checked the box for desktop icon, none appears; nor does it appear in the "start menu".
    FWIW, I normally use this PC under a normal user account for security reasons and the installer did request administrative priviledges which I provided.
    Also, wouldn't this thread be more appropriately placed in "Development Tools"?
  • Yes I agree, the thread would be better in the "Low Power RF Tools" forum but for one or the other reason I'm not able to move it for the moment.

    Anyhow, that will not solve your problem. Are you able to start SmartRF Studio by clicking on the exe file directly? You normally find that under ../SmartRF Studio 7/bin/startup_window.exe

    The problem with these kind of issues is that we are not able to reproduce the same behavior. I have tested the installation on a Windows 8.1 machine and that didn't gave any problem.
  • It does seem to start and run ok.  I have not had the opportunity to test further since I'm not sure how to proceed.  I have two CC110L booster packs and several different launchpads (MSP430G2553, MSP430FR5969, MSP432P401R, TM4C123G, TM4C129E)...

  • You can take a look at the code example here: e2e.ti.com/.../223754

    Use SmartRF Studio to generate the register setting and copy paste into the code.