This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC1120: cannot see any output in the 429.25MHz band.

Genius 5165 points
Part Number: CC1120
Other Parts Discussed in Thread: , CC1175

Hi experts,

My customer is using a CC1120EMK-420-470 daughterboard to check operation, but it is not outputting at the value they think they have set for the 429MHz frequency. The host microcontroller is not TI.
 
They are set to 429.25MHz + 0.0018MHz with a register setting that makes the output at 10dBm. However, what they were able to observe on the spectrum analyzer is 377.5 MHz, which is 4 dBm.
(FREQOFF:0x0CD, FREQ:0x6B4CCC, PA_CFG2:0x37)

Is there something wrong with the settings?

Or should we use the parameters set in SmartRF Studio?
(Select CC1120 and open the control panel->change "Carrier Frequency" to 429.25MHz->use Register Export)

If you have any documentation on the proper setup procedure, it would be appreciated if you could share it with us.

Best regards,
O.H

  • Hi O.H.,

    The best option would be to export the parameters from SmartRF Studio like you suggest - this minimises the potential for error and will likely reduce time spent debugging.

    Please advise the customer to try this and see if it resolves their issue.

    For documentation, please refer them to SWRU295E (CC112X/CC1175 Low-Power High Performance Sub-1 GHz RF Transceivers/Transmitter User’s Guide): https://www.ti.com/lit/swru295

    Regards,

    Zack

  • Hi Zacl,

    Thank you for your reply. I understood.

    Ask the customer to confirm using SmartRF Studio. After reviewing the results, we will contact you again if we have any additional questions.

    Best regards,
    O.H