This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC3235SF: CC3235MODASF12MON cannot write to the built-in flash

Part Number: CC3235SF
Other Parts Discussed in Thread: UNIFLASH, LAUNCHCC3235MOD,

I connected the XDS110 on LAUNCH CC3235MOD to CC3235MODASF12MON and tried to write a binary file with UniFlash, but the following error occurred and I could not write.

-------------------------------------------------- -------------------------------------------------- ----------
[XXXXXX] [INFO] Cortex_M4_0: Please check if the image built is based on the connected device
[XXXXXX] [INFO] Cortex_M4_0: Image Creator tool generates specific SLI image based on the device properties
[XXXXXX] [ERROR] Cortex_M4_0: Post programming was unsuccessfully executed
[XXXXXX] [ERROR] Cortex_M4_0: [ERROR_MESSAGE]Process is failed!
-------------------------------------------------- -------------------------------------------------- ----------

In the following forum, there was a note that binary files cannot be written without connecting an external flash.
However, although the LAUNCH CC3235MOD does not have an external flash, it can be written with XDS110 + UniFlash. based-hardware

What's the difference?

Best Regard.

  • All the modules comes with an external flash (32-Mbit SPI serial flash) - so the external flash is not the issue. SF devices also contains an internal 1MB XiP flash that is not accessed directly by Uniflash (the bootloader will copy from image from the external Flash to the internal).

    When do you get this error? upon connecting to the device or when trying to program it?

    Where you able to work with uniflash before (e.g. on the module on the LAUNCHCC3235MOD)? 

  • Thank you for your reply.

    This error occurs when I try to program the device, not when I connect to it.

    Also, I was able to use UniFlash before when I tried to connect to and program the LAUNCH CC3235MOD module.

    > All the modules comes with an external flash (32-Mbit SPI serial flash) - so the external flash is not the issue.

    I'm currently trying to program a SF device mounted on my own hardware. Do the above conditions apply?

    Best Regard.

  • If it is an SF device and not a module then you might need to add the external flash.

    I suggest you go through the HW review process:

  • thank you for your reply.

    What is the difference between a module and a device?
    I think I have the module in hardware.
    At least, it looks the same as the package on the LAUNCH CC3235 MOD.

    Then, when I connect to CC3235MODASF12MON with UniFlash, I can't see the built-in flash.

    Current Mode: No file system
    Storage Capacity: N / A
    Formatted Capacity: N / A
    Available for User Files: 0KB

    Do I need to connect an external flash outside the module package?

    Best Regard.

  • if you are using CC3235MODASF12MON  - then it is a module that contains the CC3235SF SOC + all required clocks, SPI flash, and passives (see

    You don't need another external flash as it the SPI Flash is already available in your module.

    Please got through the hardware review to verify that you are not missing anything else in your design.