This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS6598X-CONFIG: TPS65987DDJ: TPS6598X tool config issues

Part Number: TPS6598X-CONFIG
Other Parts Discussed in Thread: TPS65987DDJ,


We are trying to flash a TPS65987DDJ with your TPS6598X-CONFIG tool V6.1.1, 64bit. However, we have having problems getting our C232HM-DDHSL-0 FTDI USB to I2C adapter to communicate with your program and our device. We have individually tested our board to see if the TPS65987DDJ device appears and that is working. When trying to configure the USB to I2C adapter in the, "USB to I2C/SPI Adapter Settings", we are getting a,

"Exception Encountered during I2C Address Sweep: *** ERROR in FTDI call (I2C_OpenChannel), status: 1

<type 'exceptions:Execption'>

Show Details:

"Traceback (most recent call last):

  File "dialogWindows.pyc", line 8906, in sweep_handler

  File "hw_interface.pyc", line 187, in hw_open


We are using the standard TPS65987DDH configuration project. We are using Windows 10 Education Edition Build 1909.

We have tried using your 32 bit version, however, that caused a different windows error alerting us that it was not compiled for our version of windows.

We have tried re-installing drivers from the FTDI site after the intial few attempts and still, no success.

Any help at your earliest convenience would be greatly appreciated.

Thank you,