This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DS90UB954-Q1EVM: ub954 can not communicate with ub933

Part Number: DS90UB954-Q1EVM
Other Parts Discussed in Thread: ALP


I’m using a camera with TI933 serializer and trying to connect it to 954 deserializer,

when I connect the camera to the 954evm evaluation board, the Analog launchPAD can not detect the 933 serializer address , please see the image:

The 954evm configured with the following setting to be compatible with the camera:

POC voltage = 12 v

I2c voltage =3.3 v

Mode: Raw12/HF

And the 0x04 (device status) register does not show any errors:

But the ALP does not detect the address of the 933 serializer and does not allow me to update the values of any register in the 933 serializer (in the camera)

Any idea or suggestion to solve this please?


Thank you,

  • Hello Osama,

    have you enable I2C Pass-Through in the 954 register 0x58 ?

    Did you chose the right RX port in the 954 register 0x4C ?

  • Hello Hamzeh,

    Thank you, the problem solved.

  • HI Osama,

    I met the exact same issue, could you pls kindly help how this problem is solved?


  • Hi Ted,

    I tried different values for register 0x58, the value 0xf8 works in my case


    # "enable pass through"

    WriteI2C(0x58, 0xf8) # enable pass through

    The address in the Analog lunchPAD will not change (0x00), but you will be able to access the registers of the 913 and if you click on “scan connected devices” you will able to see the 913 address.

  • HI Osama,

    If I click the scan, i can only see one address pop out, which is the DES address. In my case the SER is 933 however it always show the 913A and the address 0x00... Just like yours. Are you sure that your SER address 0x00 is correct?

  • Hi Ted,

    How do you connect the ser/des to the PC? in my case PC -->  954 des --> 933 serializer,

    When I scan for devices before setting 0x58 register to 0xf8 , the software detect only the 954 deserializer  (7a) ,

    after setting 0x58 register to 0xf8 , it detect both the serializer and the deserializer devices and enable me to access the 933 registers  ,

    but the 933 register 0x00 (address register) return 0x00 ,

  • HI Osama,

    My case PC-> 936 -> 933. The picture is as below. In remote register tab all the value is 0x00.

    Are you able to correct access to the remote register?

  • Hello Ted,

    If you are using DVP (i.e. 913A or 933 SER) then you need to write in the 954 reg 0x58 the value 0x58. But if you are using CSI Mode (935 or 953) in synch Mode, you need to write in the 954 reg 0x58 the value 0x5E.

    Make sure to select the correct RX port in the 954 reg 0x4C before changing reg 0x58 and communicating with the SER.

    In the Future, please create new thread for your question and feel free to refer to other older thread.

  • Thanks Hamzeh.

    I've tried both suggestions you mentioned in the Email, the 0x58-> 0x58 and 0x4C -> 0x01, however the 933 still not recognized.

    Sorry for the confusion, just my questions/issue basically exactly the same as Osama mentioned here.

  • Hello Ted,

    from the screenshot you have provided, it looks like the 936 can see the 933.

    Once you want to access/change the remote registers, you need to select the correct RX port from the drop-down option on the Top-right.

    The SER address in the main page will not change, it will remain 0x00.

  • Hello Ted,

    If the problem not solved yet, can you give more details about the hardware?

    Are you using EVM boards?

    How do you provide the power? 12v to the 954 or 936 In your case

    The EVM board setting mode (mode, PoC voltage setting, …)


    I did some experiment today, when I connect 954EVM to 933EVM and the setting for the 954 is:

    POC = 7.9 volt

    And using port 0 of the 954EVM

    The communication is ok, the 933-board address is 0xb0, scanning the ports shows both ser and des addresses.

    But when I connect different 933 boards {from old FPDLINK camera} , I  have the problem (933 address = 0x00)

    The Analog LaunchPAD Cannot detect the 933 serializer address


    But after I run the following script :


    import time


    board.WriteI2C(UB954, 0x01, 0x01)


    print ("Devices Reset")

    board.WriteI2C(UB954, 0x4C, 0x01) #Enable Port 0 writes

    board.WriteI2C(UB954, 0x58, 0xf8) #I2C Pass through Enabled and BC = 50Mbps

    then scan the i2c devices, give me the address of the 933 serializer address


    Then , I used the address 0xba in the scripts to access or change the registers of the 933 serializer:




    board.WriteI2C(UB933,0x02 , 0x0c)      #pass through 933

    board.WriteI2C(UB933,0x06 , 0x20)      #

    board.WriteI2C(UB933,0x07 , 0x20)