This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

SN74HCS125-Q1: could you please help provide the Pspice model for SN74HCS125?

Part Number: SN74HCS125-Q1
Other Parts Discussed in Thread: SN74HCS125, TINA-TI, SN74LVC1G17

Customer was asking for the PSpice model of SN74HCS125-Q1 for the simulation. Could you please help provide that? Thank you.

  • You can use the model for the SN74HCS125, which has the same electrical characterics as far as the model is concerned.

  • Clemens,

    The model downloaded was in .cir format. Could you please help share how to create the expected library file? Thank you.

  • In TINA-TI, "Tools / New Macro Wizard". Other software might have other mechanisms.

  • Hi Clemens,

    Customer tried create the .lib and .olb files based .cir file, using Pspice, to create the library, but it failed to run the simulation. And the same steps worked for SN74LVC1G17. Highly appreciated with your further guidance here.

  • Hey Aki,

    I've assigned this thread to our modeling expert to assist you, please allow them time to ramp up on the issue.

  • Hi Aki,

    I have made some edits to the code to help get the .lib file. Can you please check if it works?




  • Hello Karan,

    Actually I am the customer who posted this question to Aki. Thank you very much for sharing the .lib file

    Ive created the olb file using the Model Import Wizard command in Model Editor. And Ive placed the .lib and .olb into this path: C:\Cadence\SPB_16.5\tools\capture\library\pspice

    When I tried to add the library in Pspice, this error message appears:

    ERROR(ORCAP-1765): Unable to load the library.

    And I could not go further.

    Is it because I created the .olb wrongly, or there might be small problems in the file?

    Thanks again



    XU Miao

  • Hi XU,

    I've asked our PSpice for TI team to take a look to see if they can help. It may take up to 24 hours for them to see this/respond.

  • Hi Xu,

    I have run the spice file so it works fine for me. I have attached .OLB file that I created. There maybe something with PSPICE that is causing the trouble for you to use the device. It is a square shape but it should work. Just make sure to choose the new .lib file in the simulation




  • Hi Karan,

    Thank you for the .olb file. I've put the .olb file in the path C:\Cadence\SPB_16.5\tools\capture\library\pspice where I put all the library, and added the .lib file that you gave me last week in "Simulation Settings - Configuration files"  but that still can't work.

    The error message is 

    ERROR(ORPSIM-15108): Subcircuit LOGIC_INPUT_HC_1i_AND_Tristate_ST used by X_U1.XU1.XUA is undefined

    ERROR(ORPSIM-15108): Subcircuit LOGIC_INPUT_HC_1i_AND_Tristate_ST used by X_U1.XU1.XUB is undefined

    ERROR(ORPSIM-15108): Subcircuit LOGIC_INPUT_HC_1i_AND_Tristate_ST used by X_U1.XU1.XUOEZ is undefined

    ERROR(ORPSIM-15108): Subcircuit LOGIC_FUNCTION_2_HC_1i_AND_Tristate_ST used by X_U1.XU1.XUG is undefined

    ERROR(ORPSIM-15108): Subcircuit TPD_HC_1i_AND_Tristate_ST used by X_U1.XU1.XOUTPD is undefined

    ERROR(ORPSIM-15108): Subcircuit LOGIC_TRI_STATE_OUTPUT_HC_1i_AND_Tristate_ST used by X_U1.XU1.XUOUT is undefined

    ERROR(ORPSIM-15108): Subcircuit LOGIC_ICC_HC_1i_AND_Tristate_ST used by X_U1.XU1.XICC is undefined

    Is it possibe that we arrange a video meeting to find out the problem? 



  • Hi Miao,

    How did you add the LIB file in simulation settings? Can you share a screenshot?


  • Hi Zhu

    Here is the screenshot. I've tried both "Add to profile","Add to Design" and "Add as Global" but none of them work



  • Xu,

    Since you have a simulation profile, you must have a schematic in which you've placed the symbol SN74HCS125 from SN74HCS125.OLB, correct? You don't need to place SN74HCS125.OLB  into C:\Cadence\SPB_16.5\tools\capture\library\pspice as that does nothing.

    I don't have 16.5 but I tried this in 17.2 (creating a schematic, placing a symbol, create a sim profile, adding the LIB file to design) and the simulation went on without a problem:

    Would you please archive your project and share it here?