This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Problems with Stellaris Launchpad ICDI drivers in Windows 7


I having some issues with ICDI drivers in my Windows 7 PC (CCS Version: Really coundnt figure out what  is going on. =(

Following the "Quickstart-Driver-Installation.pdf" document, in theory I should follow the steps below:

1) Go to Device Manager, I should see three "In-circuit Debug Interface" devices inside "Other devices" (with the yellow exclamation icon)

2) Right click on it e select "Update Driver Software"

3) Select the driver folder and install it.

4) After installed, "scan for new devices"

5)  Repeat the installations steps for the remaining devices.

My problem is that after step 4 all devices completely disappeared in Device Manager. When I unplug/plug the board Windows doesnt take any action (doesnt recognize the device, like I am not even plugin the board in).

Every time I try to debug via CCS I get the following message: "Error connecting to the target".

LM programmer is also not working.

I already tried to:

- Uninstall CCS, delete C;/ti folder, reinstall CCS with admin privileges.

- Uninstall drivers manually and reinstall in Device Manager. I am actually able to install the drivers manually but all devices are showing the yellow exclamation point. Seeing the properties of the devices I get the message "This device cannot start. (Code 10)" in the device status box.

- Change COM ports

- Restart PC several times

- Tested with a different stellaris launchpad board (I have two boards).

- Update my Windows 7.

I hope you guys can help me with these issues!! =)

Thanks in advance!


  • Hi agk,

    Do you know how recent the drivers you're using are?  I have heard that there were some issues with the ICDI drivers that were released with Launchpad, but that the drivers available on our download site have fixed those issues.  You can find the latest version of the ICDI drivers available for download at

    Also, try taking a look at the Stellaris ICDI driver installation guide, which can be found at  You can find the steps for installing with Windows 7 starting at page 7 of that document.  Also, note that when the drivers are properly installed, they will populate the Ports (COM & LPT) and Stellaris In-Circuit Debug Interface sections of the device manager, which I believe will be collapsed by default in the device manager when they are properly installed.

    Give that a try with the most recent drivers, and let me know if you still have any issues.


  • Hi Jordan,

    Thanks for the fast answer!

    I completely removed all the drivers and installed the versions above, still didnt work.

    Then I have downloaded a USB sniffer e saw that there was no USB traffic from the board, like if the board not even exist.

    I changed the USB cable and worked like a charm =)

    It was a simple problem, but it took me several hours to find out... =( Some USB data line should be damaged since the RGB led program was executing normally.

    Thanks anyway,