This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TM4C Error connecting to the target: (Error -1063 @ 0x0), Unresponsive Processor.

Other Parts Discussed in Thread: UNIFLASH, DK-TM4C123G, TM4C123AH6PM, TM4C1290NCZAD


Ive been running into this error code for weeks now:

CORTEX_M4_0: Error connecting to the target: (Error -1063 @ 0x0) Device ID is not recognized or is not supported by driver. Confirm device and emulator configuration is correct, or update device driver. (Emulation package 

When attempting to debug a custom board with 3x TM4C123AH5PM processors using CCS Version: over JTAG with a XDS100v2 debugger. The processors originally would debug to the console using the sample hello world project but all resulted in the same error code once loading a project including the driver libraries. 

I ran the debug unlock tool using Uniflash however i'm still no further.

Can anyone help?


  • Can you answer the following:

    1.)  What is the exact device you are using? 

    2.) Is this on an evaluation kit, or your own custom board?

    3.)  Prior to lock up, did your software write to EEPROM (or initialize EEPROM registers)?

    4.)  There is a silicon version that is on your part marking.  Can  you tell me what it is?

    5.)  I see you are using a XDS100v2.  Can you tell about your JTAG connection?  In other words, are you using jumper wires to connect to TMI, TDO, TDI, and TCK?  or are you using a connector provided by ti?  if yes, is it a 14 pin? a 20 to 14pin converter?



  • Not as highlighted as we'd like - but he does note a, "custom board."

    Also - possibly of importance - there are 3x MCUs on this custom board.  Might these be (JTAG) daisy chained?  If not - are JTAG pull-up Rs in place @ each/every MCU - that custom board?  And - might those 3 MCUs share some signals/connections?  (i.e. Reset lines/others tied together)

  • The MPU's are on a custom board used to drive 4 BLDC Motors. The devices are: TM4C123AH6PMLQFP_64_10X10. One MPU is acting as master and the other two as daughter connected via SPI.

    Each MPU has its own reset line connected to the +3.3v line through individual 10k pull up resistors as specified in the design manual. 

    Im using an XDSv2 using a 10pin header, the pins are connected to TMI, TDO, TDI, TCK & RST of the respective MPU.

    If there is any other information you need, please ask.

    Thankyou for your help

  • To further assist Ms. Garofolo in diagnosis - is that one, single 10 pin header - connected to all 3 MCU JTAG lines in parallel - or 3 separate, 10 pin headers - each uniquely routed/connected?  (I cannot tell - from the posting)

    See that reset is properly pulled-up - but unclear as to pull-up presence on JTAG lines - each/every MCU...

  • Each MPU has its individual own 10 pin header only connected to one MPU, they are not connected to the other MPU's. Each individual line has its own 10k pull up resistor. 

  • Thank you - JTAG routing now clear - believe this saves, "wear/tear" on vendor staff.

    One last point: "Processors originally would debug to the console using the sample "Hello World" project - but all resulted in the same error code once loading a project including the driver libraries."  By my read of "hello.c" - part of the DK-TM4C123G FW Package - more than 10 driver library code .h files are included.  So - it may be that your new project may lack some needed file path/reference - or introduces some other issue.

    If it is true that you one time succeeded in loading example, "hello.c" code into one (or several) of those MCUs - your JTAG connections appear valid.

    Believe that LM Flash Programmer may recover your MCUs (one by one) - but not w/your present JTAG tool.  Poster Petrei - iirc - has determined that "Uniflash" may achieve that role w/your JTAG tool. 


  • I used the hello world example as part of the CSS example project files. This project does include the arm compiler header files. The error occurred when attempting to load the SYS\BIOS example project specifically for the TM4C123AH6PM included in the Tivaware library.

    Thanks again for the help

  • That further report should assist.  I'm far out of my league as regards CCS and/or SYS\BIOS - our group uses IAR & J-Link.

    Info you've presented should speed & enhance Lela's - and/or other's efforts to resolve.  Good luck...

  • Thanks for your help

  • We found an issue in your schematic, C63 on pin 25. According to the datasheet the VDDC pins should be connected to each other and an external capacitor in range of 2.5 - 4.0uF total (, page 1328).  You connected 3.3uF + 3.3uF = 6.6uF.  This could be causing the MCU to execute through the power up sequence incorrectly, set an internal error and not release CPU. To end user, device will appear to be “locked-up.”

    Please correct this and report if there are any changes.

  • Any updates on the problem? I have a similar issue with TM4C1290NCZAD.

  • Hello Kir

    This is a 4 year old thread. Since then we have published the JTAG Application Report for debugging the issue. Please refer to the following document.
  • Thank you Amit