This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

EVM430-FR6043: Problems with enabling 5V drive of EVM

Part Number: EVM430-FR6043
Other Parts Discussed in Thread: TPS61240

Hi team,

I am using the EVM43-FR6043 and attempting to use the included DC/DC converted for 5V drive. I followed the intructions in the hardware guide to set up JP1 & JP2 for 5V, but it is not working. 

Everything works for 3.3V drive. When I probe with a MM, I can see that the Tx5VEn (R73) is pulled low so the MCU is not correctly enabling the TPS61240.

It appears to be a software problem since I tried a second EVM right out of the box and the same thing occurred. Everything worked at 3.3V, and the 5V mode fail with the Tx5VEn staying low.

I do not have software expertise, but assume this is the problem. I see the pin being referenced in the USS_Lib_HAL.h (line 151), then use in the .c file:

#if defined(__AFE_EXT_5v0__)
// Initialize TxPwr gpios (clear gpio and configure as output)
USSSWLIB_HAL_AFE_TX5VEN_PORT &= ~(USSSWLIB_HAL_AFE_TX5VEN_PIN);
USSSWLIB_HAL_AFE_TX5VEN_PORT_DIR |= (USSSWLIB_HAL_AFE_TX5VEN_PIN);
#endif

Is the P1.1 being initialized, and used correctly? 

Best regards,

John

**Attention** This is a public forum