This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS with new MSP-FET - no connection to MSP after updating firmware this morning

Other Parts Discussed in Thread: MSP-FET, MSP430FR6989, MSP430F2418, MSP430FR5969, MSP-TS430PZ100D

Hi everyone!

I have a really big problem...this morning CCS downloaded and update an then also wanted to update the MSP-FET - after finishing both updates there is no chance to connect to the MSP anymore. CCS says:

MSP430: Error connecting to the target: Legacy version of silicon used, which is no longer supported. Please contact TI to obtain a newer version.

I have to go on working on my project!! I'm using a MSP430FR6989 which is not officially released yet, but until yesterday everything worked fine.

Any idea?

  • Hi Dennis,

    Dennis Eichmann said:
    Any idea?

    Which CCS version are you using? Also, try updating your CCS to latest sub-version and then plugging-in your device.



  • I'm using Version and, as mentioned, just updated this morning. I have already plugged in/out everything several times and also made some restarts of my system. Everytime there is the same error message now.

  • This is the error message box:

    I have also tried using another MSP, but the problem still exists. Even another FET produces the same error. Unupdated and updated! Is the FR6989 no longer supported...??!

  • I feel some glitch has been introduced due to this update and should be resolved with another update. I'm forwarding your query to an expert for a quicker solution.



  • Thank you very much!

    I have now tried to communicate with another MSP on another project - it is a MSP430F2418 - this works fine, no problems at all. But if I then try to hook up to the FR6989 the error message pops up again.

  • See

    MSP_Debug DLLv3,, released Sept. 3, 2014:

    • Early MSP430FR6989 family silicon (older than revision C) is no longer supported
    • Early MSP430FR5969 family silicon (older than revision F) is no longer supported

  • Hi!

    That is the answer! Thank you very much. I haven't seen that document before. So there is no error in the software update...:-)

    Anyway...why do I get samples from Rev. B? I have just ordered them not so long ago. They were included in the MSP-TS430PZ100D board. Meanwhile I uninstalled  version CCS V6.0.1.00040 and installed the prevoius version .00039 again. That helped me go on working with my samples.

    So...thanks again for that information!


  • I agree that this is an unexpected behavior. Sometimes, older silicon revisions are so buggy that continuing support makes no sense. The data space for chip information in the FET is limited, so removing more or less useless information (especially if the target anyway doesn’t work as it should) is understandable.
    For samples (especially for free samples) of course not the newest and best are sent out, as long as there are still older ones. Also, existing packages on stock are nor re-packaged.
    I agree that nothing that is sold or otherwise delivered should be a version that is already obsolete and no longer supported.
    Apparently the decision to end support for those silicon revisions was not (or not properly) communicated to the shop and didn’t trigger re-packaging of the bundles that contain those processors (which is a logistic nightmare).

    I forwarded this issue to one of the 'officials' and there will be better coordination between tools development and sales department in future, regarding droping support for outdated silicon.

**Attention** This is a public forum